summaryrefslogtreecommitdiff
path: root/dev-python/python-constraint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-python/python-constraint
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-python/python-constraint')
-rw-r--r--dev-python/python-constraint/Manifest4
-rw-r--r--dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch11
-rw-r--r--dev-python/python-constraint/metadata.xml20
-rw-r--r--dev-python/python-constraint/python-constraint-1.4.0.ebuild23
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/python-constraint/Manifest b/dev-python/python-constraint/Manifest
new file mode 100644
index 000000000000..0b6c14ab53ef
--- /dev/null
+++ b/dev-python/python-constraint/Manifest
@@ -0,0 +1,4 @@
+AUX python-constraint-1.4.0-exclude-examples.patch 649 BLAKE2B c5a5e1d425dfebfd377b36409115e947ac7154acdda557b0a494a029425e1f411b8cd59e004fc40575a1f1e377efa1a17470842626dcf7c636eddb86df57d700 SHA512 7e66113cbaf20ec5094bda0416123d9d26e2185951ce864d8d5b054af1ec9a2515ac458165d773535f97daaa2a76d32a336444055fcb7cbe62547e03dbcff2d5
+DIST python-constraint-1.4.0.gh.tar.gz 24966 BLAKE2B 5ada7926f226536a1384bf9a082da41824e46d683ee71a278c50e1e5ca0a21eb3acbde4c0b47d6b48c53864ab4ea47d602fc9acb976423035aee74b0c6f3ed85 SHA512 fbc65ba5854e227e62469290e2d8362ed3247931592e2ac7eb5bcd5d3f9f720bbab8a984a8f7cf9dce989663f13965c5401286a1bdc673c2c076c8b22e19f0cd
+EBUILD python-constraint-1.4.0.ebuild 588 BLAKE2B c821389d00dae29630dcd56f8dbd3eff6180b835f399928547526f0ce3d24105f2157a612dcd6bf49e8d6b2e2ed92a552e279eff83c021d907c5dfb90880be35 SHA512 0179829fec754cc738075cbc3bd8c2d10a4fa00b577b49e699e40b9e20712cef680af25cf9bc88b72760f81c623a7bc6a45864ab2639f989d4919eeb2c1a5c0d
+MISC metadata.xml 947 BLAKE2B 2500fe151e9d0dc41ffa207567e11dbca3d7d6ca08ff2c70a3325e33105b8f8d2f02b0052075fba0ce3bdd02621ce10f67c284999d2fc09269e63e7d4f646026 SHA512 64c524a09ce0bc157684ea88bee42a3f8808c1ee4217d26555018cb61502f8beb20413f0b995a0d130b3482b4e35742029ad32ffb096bc0e2a5a76cf3414a3c9
diff --git a/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch b/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch
new file mode 100644
index 000000000000..797b8e18cff5
--- /dev/null
+++ b/dev-python/python-constraint/files/python-constraint-1.4.0-exclude-examples.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2022-02-27 15:57:35.035889587 +0100
++++ b/setup.py 2022-02-27 15:58:04.049889476 +0100
+@@ -70,7 +70,7 @@
+ keywords="csp constraint solving problems problem solver",
+ # You can just specify the packages manually here if your project is
+ # simple. Or you can use find_packages().
+- packages=find_packages(exclude=["contrib", "docs", "tests*"]),
++ packages=find_packages(exclude=["contrib", "docs", "tests*", "examples*"]),
+ # List run-time dependencies here. These will be installed by pip when your
+ # project is installed. For an analysis of "install_requires" vs pip's
+ # requirements files see:
diff --git a/dev-python/python-constraint/metadata.xml b/dev-python/python-constraint/metadata.xml
new file mode 100644
index 000000000000..a8c024c1f192
--- /dev/null
+++ b/dev-python/python-constraint/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Python constraint module offers solvers for Constraint Satisfaction Problems (CSPs) over finite domains in simple and pure Python. CSP is class of problems which may be represented in terms of variables (a, b, ...), domains (a in [1, 2, 3], ...), and constraints (a &lt; b, ...).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-constraint/python-constraint</remote-id>
+ <remote-id type="pypi">python-constraint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-constraint/python-constraint-1.4.0.ebuild b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
new file mode 100644
index 000000000000..e7a17dd7f275
--- /dev/null
+++ b/dev-python/python-constraint/python-constraint-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Constraint Solving Problem resolver for Python"
+HOMEPAGE="https://github.com/python-constraint/python-constraint"
+SRC_URI="https://github.com/python-constraint/python-constraint/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/python-constraint-1.4.0-exclude-examples.patch"
+)
+
+distutils_enable_tests pytest