summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
commitd8616435f08981d5bc3df9f348190309a7bdbbc0 (patch)
tree6c51fc295fb9c2f5511a7ebb14fab377a5f8e171 /dev-python/python-cinderclient
parentfa1962ff69701bd9c0f15fb225cdbfb487125e0e (diff)
gentoo auto-resync : 16:07:2022 - 01:44:25
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest2
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index b6d5d4a59b0f..2637078ea401 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,5 @@
DIST python-cinderclient-8.3.0.tar.gz 234371 BLAKE2B 092d7abdd348f5fac750efb3f3f4df1575584684ad613d22c558630576ad2f82c399af671aad7070dd224a89fa01d73333c2505dc0166d2e4c70e21ac01f298d SHA512 4d633b39a3c59cfdc2fc2c6235b3b87093f7617c89a80b50cf26d8f6fd63e8c3197d788e0b9e81347b9427cf363289b09b85376512d5820031472a735e0ca839
+DIST python-cinderclient-9.0.0.tar.gz 234533 BLAKE2B 18d673cbe02c5a4221b8667d051b1e0c1cbfe0c071e2b8c2f37b37dcf4ea9adae7ee64a7d5c8663c8ebd5946be53d91e253b9fb1df75e0d7f4dd8554098d22db SHA512 66542e10041d567fd7193a577ea5e8e7de6d7f735e05b1135f5d41e88847a6d042356431f54b481d9c13ec99c56e6d898df0222737e17c21fe6be6cfa886eafe
EBUILD python-cinderclient-8.3.0.ebuild 1237 BLAKE2B 83416e79a26d7c137d7a8871a11d5e1203d438cbb04d2719f862663e76e94ca5e5288ac25bd838468f3fa6eae4f0fdef20ddb58c67b0d83b40563022ab960c4c SHA512 e512063e57ab396f5673a3ff3334631808393b033cc764670a23a9b590e5f6caf70ddcedeb6c017c8da220b33aea40bf790fa6bf716bb623bd5dfc46d660b2af
+EBUILD python-cinderclient-9.0.0.ebuild 1239 BLAKE2B 8400d04b62c26500ddb25ed6677c49f3349825bc77f22fc4b26505a419c1c5283c2e459a55b93cab882986d00f9f04d929b551cf035a115de281c9fa199bab67 SHA512 123f9daa1e9befee64a822446fcab70b122823ca24376556e7a52014ce794997ea3f454b0b95ac31cc60e7530ad1c1aa472450922d7123fe2a199f20863722f2
MISC metadata.xml 727 BLAKE2B 0017cc08edf25f27b8a2816bc3ce1374148a17522bf2c5ea643ad10cde9f5779b1b6bf1e3c91627db76d2f77b8dcbfc87a29fb2cdd8064b3140fb14d1e6e00a1 SHA512 e30e64371f7a5f5fa506396f2edbbc7f862a585c7fe9af4f6fe63e99d4bbe9f9bf3a1f002a62c40ab9d75bd90ab99446bb80bf7f2fedf5b37287eeb54e5dacbe
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.0.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.0.0.ebuild
new file mode 100644
index 000000000000..69b8678ff2eb
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}