summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /dev-python/python-cinderclient
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest2
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 1d92967760ac..89195ceb105c 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,5 @@
DIST python-cinderclient-9.0.0.tar.gz 234533 BLAKE2B 18d673cbe02c5a4221b8667d051b1e0c1cbfe0c071e2b8c2f37b37dcf4ea9adae7ee64a7d5c8663c8ebd5946be53d91e253b9fb1df75e0d7f4dd8554098d22db SHA512 66542e10041d567fd7193a577ea5e8e7de6d7f735e05b1135f5d41e88847a6d042356431f54b481d9c13ec99c56e6d898df0222737e17c21fe6be6cfa886eafe
+DIST python-cinderclient-9.1.0.tar.gz 234608 BLAKE2B 9ff63454e8162d731517ce2d98b6ea0c3cf04ef5a885e30afaa67444eb7f814c1ac205a0a216c7a3b92311be5687b9e2561aa02936e87b91ca61c8ea663e069f SHA512 2aa55331d5f372cccb946a4be2e25d4cc6a1d9d9676f1f32b9b51f141d107f74bcb1d0d7a5ef94b931fc5a5ccacb43f639db635217a7833d7738296734938f8b
EBUILD python-cinderclient-9.0.0.ebuild 1237 BLAKE2B 0f562b157d1a8441fb41ff2b80ec4f3e3f0d7828356f6a12e6a223498ecae3aad862d925d643e382292fbb1c7e2948e9d0899e17df1586e75b2a39b692c8bb27 SHA512 81f10aef4f05664782698f10513a1beb28c24de9a99c1be81cd3b18d1a360bc3f24b5be4e1d82ef124464bef194a58c2f51414ee0c526f423d29028d48f0c81a
+EBUILD python-cinderclient-9.1.0.ebuild 1239 BLAKE2B 8400d04b62c26500ddb25ed6677c49f3349825bc77f22fc4b26505a419c1c5283c2e459a55b93cab882986d00f9f04d929b551cf035a115de281c9fa199bab67 SHA512 123f9daa1e9befee64a822446fcab70b122823ca24376556e7a52014ce794997ea3f454b0b95ac31cc60e7530ad1c1aa472450922d7123fe2a199f20863722f2
MISC metadata.xml 727 BLAKE2B 0017cc08edf25f27b8a2816bc3ce1374148a17522bf2c5ea643ad10cde9f5779b1b6bf1e3c91627db76d2f77b8dcbfc87a29fb2cdd8064b3140fb14d1e6e00a1 SHA512 e30e64371f7a5f5fa506396f2edbbc7f862a585c7fe9af4f6fe63e99d4bbe9f9bf3a1f002a62c40ab9d75bd90ab99446bb80bf7f2fedf5b37287eeb54e5dacbe
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
new file mode 100644
index 000000000000..69b8678ff2eb
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}