summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-cinderclient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest5
-rw-r--r--dev-python/python-cinderclient/metadata.xml19
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-3.1.0.ebuild40
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild37
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
new file mode 100644
index 000000000000..3b91f6357832
--- /dev/null
+++ b/dev-python/python-cinderclient/Manifest
@@ -0,0 +1,5 @@
+DIST python-cinderclient-3.1.0.tar.gz 278247 BLAKE2B d5fb6b3f74c70fd58cdc8a2cf2ea7a57935fd3246de035ebfc84d1acb037ff309ff1de2954c373a453f623e78b6c84bfca194f77273420eaa46ee291a2a97c28 SHA512 6d828a96802d9a5118ab3b463ed9c8619530a69a1ca153f0c3d737e26bd692864ad2ba4c79e74a18ebf820222a75b81a9735f63c989817797689d8f399f76394
+DIST python-cinderclient-3.5.0.tar.gz 284317 BLAKE2B c231b2d67071dc01521e271cdae19d0e1bb8af387780b4f855631ae248e156110888eddd63684102d5b5769840d31e622d9db1e24ecdb90ddda06e803c6586fd SHA512 0ee11c19b404c5f335422a5a18d01529330dc8d39b58c5f8b6be28a0e682858f1fea5f21bfcfc2a272a556f1a3a61fa6a0379fadbe79b65a4ad72cccf42a6223
+EBUILD python-cinderclient-3.1.0.ebuild 1267 BLAKE2B dc19312fb6b9316b45f971ceb5f62d63605bbe98fbd66a44a6ba5a73d05138b2fdae7b77a1be6ac98d7dce1b9b17584eefcd6aad542a6600bdec0818391b9080 SHA512 ecbe8642de0f31747543bf815008c29202f41c85b26d15e885a8cb0aa6552d6bde3331885e1b8fbfac7ed4624e4e1a5f2a6fcbf7a4121d0b017af838ec086ce9
+EBUILD python-cinderclient-3.5.0.ebuild 1120 BLAKE2B cb4f3c5dc930ad54a523bd9a9eaf284081b70c21ce8a406a7900be5bb69d55df85ea0296a9fb2817f7be0057e1c415f2b60871a10cccf4360467261a38dff9ff SHA512 0206fa2497c2f094ef8e225f12e355d7a2f8a2cb5b45644f7fda7e4dab1688c75761fc7ad5a38d1df5cc978caa8e541d9b4dcd68f8a4726da312a86a5c523f72
+MISC metadata.xml 625 BLAKE2B a9011769fe7ab23b5b00cdfe6e209e92186abffd4a32e6b21e2741ea8b58848b3aee384d301c3bfeeaaea3632becc5db22afcd8d6b149d17db34198a89e86ca6 SHA512 397ec06d3fb289940f654600dd452f5450ab6a87b4584f5486196a5467b7b5b9251c241c28b92a17b92da9d0a094b1a4d4ec303fe8eb3087c50a560f423bf92a
diff --git a/dev-python/python-cinderclient/metadata.xml b/dev-python/python-cinderclient/metadata.xml
new file mode 100644
index 000000000000..1270d0b5f816
--- /dev/null
+++ b/dev-python/python-cinderclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a client for the OpenStack Cinder API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-cinderclient</remote-id>
+ <remote-id type="launchpad">python-cinderclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-cinderclient/python-cinderclient-3.1.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-3.1.0.ebuild
new file mode 100644
index 000000000000..5ace769a82aa
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-3.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild
new file mode 100644
index 000000000000..784f4950cfb3
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-3.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}