summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/python-cinderclient
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest4
-rw-r--r--dev-python/python-cinderclient/metadata.xml3
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild37
3 files changed, 40 insertions, 4 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index c304657f7531..05470c4f124c 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,5 @@
DIST python-cinderclient-4.2.1.tar.gz 287696 BLAKE2B b79068acfeafd9e8ab85035fcda1cceaacc68d3a847b4d070fcb16efdf103ad362c21196afc0ea23eba6a9110f5e96d8de8e2446889740c9abccd912a972358d SHA512 e72af1163bbd882354aea3b7ecdc36cad0899589430e31006f9b1f5f1d00866c9c0de631d2a94b83b3dc358039069adefef54231ecb191ad167339ca3a37a588
+DIST python-cinderclient-4.2.2.tar.gz 289041 BLAKE2B c397c530a040f340d8b39d33348299c547f4591e0046c89644014e3ecdb1163c2b7d46111609ffb6586ed4dd70ae7c1a9f2895046ac7650d101cb6581a5f758f SHA512 fbbdf3828bc13c316c148290575a5efc349c02123bde0f965e11d504cb690fdda9c18af36aa4fc7c6289dc809b45aca41721c3f30b71d088bda2733c785c5ef9
EBUILD python-cinderclient-4.2.1.ebuild 1105 BLAKE2B 1088a04515bd0a7e5b3848ecc5232ccb46ca2320ed473c7fac289f1f0a467ca2a1dc0d332bbbd47dd58cf1f7875228aa8819d34d90579efe2eac14aac0f90134 SHA512 8dfbb8d5739d8f3f53896a6d3b4fba40d9f2f63f231f16b80e13ed96d19bc0a33067e4736ff41f28d297c783c4d445339de1106b19643c9e90090772ed683204
-MISC metadata.xml 625 BLAKE2B a9011769fe7ab23b5b00cdfe6e209e92186abffd4a32e6b21e2741ea8b58848b3aee384d301c3bfeeaaea3632becc5db22afcd8d6b149d17db34198a89e86ca6 SHA512 397ec06d3fb289940f654600dd452f5450ab6a87b4584f5486196a5467b7b5b9251c241c28b92a17b92da9d0a094b1a4d4ec303fe8eb3087c50a560f423bf92a
+EBUILD python-cinderclient-4.2.2.ebuild 1107 BLAKE2B 139792f2ae2aa4466f5236a295bb92242556eceabab4ce02a2ef3432bf9738d5ee2e89bd289c3d8584c612b2102e3b65d9a3c02c5892087f15d9cdf3a079b5d8 SHA512 aa9f6bc4a9f8998f0236462671c7a91a95a6267973b5cc42de7fdfca815bdc40ddc16321f1dbed2ef2d5612868575e51f3666801375aa8437d43f8775ea81fb4
+MISC metadata.xml 523 BLAKE2B 7326fec05abafc1316ddfef15561f63a358e7ac03eca46ba473b52998e735df59feabbd65a98a23f4c233ef675c20b6cb391752b34cf89914a03aa1cd1ba04ee SHA512 31f96809c9fdfcabaed51965bb490bc5726d0cf2d4a3b2866945a25c0a67af6b60f2e80dabe21ee015f69e810dabbd0c093a58b73f454786c363e6f6e29e975f
diff --git a/dev-python/python-cinderclient/metadata.xml b/dev-python/python-cinderclient/metadata.xml
index 1270d0b5f816..89b79ab63e40 100644
--- a/dev-python/python-cinderclient/metadata.xml
+++ b/dev-python/python-cinderclient/metadata.xml
@@ -9,9 +9,6 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
- <longdescription lang="en">
- This is a client for the OpenStack Cinder API.
- </longdescription>
<upstream>
<remote-id type="pypi">python-cinderclient</remote-id>
<remote-id type="launchpad">python-cinderclient</remote-id>
diff --git a/dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild b/dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild
new file mode 100644
index 000000000000..5bce90942b3d
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-4.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}