summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-cinderclient
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest3
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild46
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild45
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 3cc42689de3e..14a4c2ed785a 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,6 @@
DIST python-cinderclient-8.2.0.tar.gz 233148 BLAKE2B 4ada4562ff1e51a284cf98e7ca4b324a05a4524951d6193bb4683a3986bc8a26a48373ef78613f3b94ed475992fb781b409fe58f9f3655f3f721b38f7eab770b SHA512 86e7a0c18d960f00448e20485d91443d185902db281014c99f35af463843be6d4bca80712edf44189b53e25853af064c14de18e943d9fdee29446180d9b91bbc
+DIST python-cinderclient-8.3.0.tar.gz 234371 BLAKE2B 092d7abdd348f5fac750efb3f3f4df1575584684ad613d22c558630576ad2f82c399af671aad7070dd224a89fa01d73333c2505dc0166d2e4c70e21ac01f298d SHA512 4d633b39a3c59cfdc2fc2c6235b3b87093f7617c89a80b50cf26d8f6fd63e8c3197d788e0b9e81347b9427cf363289b09b85376512d5820031472a735e0ca839
+EBUILD python-cinderclient-8.2.0-r1.ebuild 1271 BLAKE2B 789b54874ef69bd8a34dab5550718229b3c712a0a4f17816f9a53b22b869fd8f3319dec2bf4f17c6d04f4c7f71e0b8eff5892a5389f6c4865ec77c3f92f71177 SHA512 a8e0aec5428a04bd15b7bf174a9cb7ca7a8a91e9620182ab159255ca1afd0ee16e756e9f91989f379bd7a4314168eb39124b981ab6eb265fdf45bd9d07222f93
EBUILD python-cinderclient-8.2.0.ebuild 1235 BLAKE2B 118a465b5e9a78a33e41ecbb0154128271057def69e81cf9088fccbb3ccaaaf43da98f7a6f501aa8b541ec7911884dd328e1e59087fd9ab10ac35110253c6914 SHA512 f914ff39f18eeadd27dad0e5883b4305999f7a032e07a6ce84ccd945aa931129d586b45d8e6eb634f0a262c53c42f6893c694ee886e64ac7ad196205b3783f51
+EBUILD python-cinderclient-8.3.0.ebuild 1232 BLAKE2B 326ea275604c7c94a8994ae45e20de0b34ea057fec8e03c7f05bc18f4225b454920dbdcc9550a5c2e85721d57831f12928b7ddb28135eea20778d6f5982b586f SHA512 ea989eb9447f560b4eaeed498f8b6d976590ed221e58a5b9a0bd1225000923efde974005b386bc7e4b1b66d35b0173c1fd174d89f097c477370bfea9c992892d
MISC metadata.xml 620 BLAKE2B 0ae868352f45097f3cf441ccf11551a05c6264d441f7b42452ed40e8ae9b6f68a5413b4e2cf91e20eb7bbf8bef7cc8f1dcf203e0378e42b9d27f04f96dfceca3 SHA512 cae62ef195e410efe40d9b693c2526c6c966790701006a773c931ea02cf5f2f6cefc1c08f27ddc07d3306794130fe99a87e4e2fc49f573741b599145e1017915
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild
new file mode 100644
index 000000000000..285508bda622
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild
new file mode 100644
index 000000000000..610b988ad6b8
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}