summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-12 15:32:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-12 15:32:09 +0000
commitd1edfd3a57afc1db57e14cc58d3f28eea8eefd64 (patch)
treed5315c32caabd5ea57f0557a1b17681a6e12a435 /dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
parent983485e93d76602266889d23c963609073b75e51 (diff)
gentoo auto-resync : 12:11:2022 - 15:32:08
Diffstat (limited to 'dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
index 6aa69f0ac442..1195ce14c1c5 100644
--- a/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
+++ b/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -39,6 +39,11 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.11-argparse.patch"
+ "${FILESDIR}/${P}-fix-py3.11-crashes.patch"
+)
+
distutils_enable_tests unittest
python_test() {