summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
deleted file mode 100644
index 8f127cc25556..000000000000
--- a/dev-python/python-cinderclient/python-cinderclient-9.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Cinder API"
-HOMEPAGE="https://launchpad.net/python-cinderclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/keystoneauth1-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
- >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
- >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
- >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
-"
-# Tests fail with dev-python/prettytable-3.4.0
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/oslo-serialization[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- <dev-python/prettytable-3.4.0[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.11-argparse.patch"
- "${FILESDIR}/${P}-fix-py3.11-crashes.patch"
-)
-
-distutils_enable_tests unittest
-
-python_test() {
- # functional tests require cloud instance access
- eunittest -b cinderclient/tests/unit
-}