summaryrefslogtreecommitdiff
path: root/dev-python/python-caja
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
commitfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (patch)
tree3669828a2d0c5f7cb1a4bfd79be8032aac558282 /dev-python/python-caja
parent9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (diff)
gentoo auto-resync : 03:12:2022 - 02:58:11
Diffstat (limited to 'dev-python/python-caja')
-rw-r--r--dev-python/python-caja/Manifest2
-rw-r--r--dev-python/python-caja/python-caja-1.26.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
index 803389690371..a66b460856de 100644
--- a/dev-python/python-caja/Manifest
+++ b/dev-python/python-caja/Manifest
@@ -1,3 +1,5 @@
DIST python-caja-1.24.0.tar.xz 312340 BLAKE2B a860cb1cc983221710d93943ac39b9b77761997fa6a52b32dceeeec381ee86d976c56266013d0370a28e7cb26de3601fec42234b4f91c78e5ac54992035e17ee SHA512 9febf7cae1736e30c80218dcfd3cc05b948823b99945ed67c1839ab5149aa3fe05b090d46c598810f0cde8ba66b83426c4642f6ebdbef6067f6b2fbc0798e816
+DIST python-caja-1.26.0.tar.xz 314936 BLAKE2B 1fabd7bafa19051a19643aa9f10180d72062bc485231760439d988936406e07b9e600a80c1c9d45c88a5ac40c0b16e90878c02dba81f722d8a6f60713fe28cc7 SHA512 632b0b4a9fa29bdcde3b84b37820a7e171b59e78972f71c0c3d25d52cad8233ae7d1548e23ed6d3a06734b084532db1c4e85c3beaed15fce88cf8abff5be35d0
EBUILD python-caja-1.24.0-r2.ebuild 1233 BLAKE2B 37babcdb3a0b35b8ed48f02a8d0e9b9bc4248d8fb13808968551e5c4e722f6f6dde4284a435e151e2031457aeb98b114257ec8e862e9402bb06e781963f4a73d SHA512 b31f7b1c399441b3e840504e27789a7495cc698811e9d80c8e61e2b459cbe920f5555c925b11cf62bf6a5debbd89656c2cf61f528097cd7715178a4bca2a9aac
+EBUILD python-caja-1.26.0.ebuild 1237 BLAKE2B 37298dd517d9c5816f3cc1956cf07a23c1ee5031221499941d83812c2ce6c1756116d56059fd42e4afcfd18564fd6e95b7e001c68d129b109132a6831a5302c2 SHA512 4679dc9b446c500e17423f284a0dabb9a61985a889d5887415b32081f1f2a4ff26a2514f3f7ac62f92b8ba0a05af84e3f430e12b6ca3ded3c66ca245dbcc1a86
MISC metadata.xml 341 BLAKE2B 9ebf9e42c41e7c99868f84b3ecd9c8de5c5c244dc5f0ea05e61af623c682bbb784c4d10e6d0391e5fd4852cf9cb9266cd5e71f9ae258a67c993a3b0cc838eb21 SHA512 2c4c140998a6ba2eb7c17b532ba459ffd284eeb4d109b6148033ae068630af90b9ff43034e4f46a980c049a18da6fadacba26cfd877c4b45edd9eb3e9dde371b
diff --git a/dev-python/python-caja/python-caja-1.26.0.ebuild b/dev-python/python-caja/python-caja-1.26.0.ebuild
new file mode 100644
index 000000000000..378681f190a4
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.26.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_8,3_9,3_10,3_11} )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ $( python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' )
+ >=mate-base/caja-1.17.1[introspection]
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )
+"
+
+src_prepare() {
+ MATE_FORCE_AUTORECONF="true"
+
+ sed -i "s/\$(PACKAGE)/${PF}/g" examples/Makefile.am || die
+ mate_src_prepare
+}
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/caja-python/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}