summaryrefslogtreecommitdiff
path: root/dev-python/python-bugzilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-bugzilla
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest5
-rw-r--r--dev-python/python-bugzilla/metadata.xml12
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild24
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild32
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
new file mode 100644
index 000000000000..f25a148b31fd
--- /dev/null
+++ b/dev-python/python-bugzilla/Manifest
@@ -0,0 +1,5 @@
+DIST python-bugzilla-1.2.2.tar.gz 76026 BLAKE2B 1c5cba3e5abf517779d3db2e3b503a38190ec71455e23e8813ee7f495f1a3df117653141728a53781c1acebadc1781614937413d13698eda289f59e5738647c2 SHA512 bb4ce43ffbf054097bd537404861848dd4ff5883fa63f156dfa90bea9f2e89cfaf0670980ec290a3d9c90cee268709b914e8bd5bd38b7f2e29c8d7fbd0215ac2
+DIST python-bugzilla-2.1.0.tar.gz 78791 BLAKE2B 31819e04ea5627b5513c22e9cb963cdea4d1ef8d6d4db78d14bf08b8b5fb373afaad4bddb2bc0b05d4637f966bf8b4f3699ace58ceff8ea226d9ffd4aacc7f61 SHA512 40dd331e2dbb4d70ce6d356eb800d6242ef9878112310087761c8dccb7f05b259f0f5fdee6821713a84c68f1e5f9e0bb6ee45542bc385f00822b97344371239e
+EBUILD python-bugzilla-1.2.2.ebuild 626 BLAKE2B 8ed24f398c3ec0d325ddae32f1304d6bffc0fb808badb344c09bf1557b931bda824cde73a5ac9d6b864628fd28df63027194ca2ddbfdd6ca6ba0ea0256cd1db4 SHA512 626627e1b879f6d83b248769d09443ea26d86de6ef99c3740d96be08b5c53651e6b9e1fb746ae1402ac71d8bf1f260250f60ca883f758e8fe1b5986aecdd94f1
+EBUILD python-bugzilla-2.1.0.ebuild 733 BLAKE2B bba29c906683600d0de716d0c276c4318b09f27d8772959e87fd0c9c7500aeca00c5e91da5146beec076ef01ed939067afdbd73d05c575c38d829bb00ca53aa2 SHA512 d0bbb64d1d2d22b2bf7e890a5409af3501f4dec6f4d2d486ec82c4b3997537d8dc552bbe1f5e035f25b1bbe43cf52b136715b1766efa000b4524d8e44b8f9e28
+MISC metadata.xml 415 BLAKE2B 37720f51243092b0e7a73a1489d43df6f089a95fea6a406d277fa2874d852b5768fb504a0886a424ba555e09c250342108353599f6302350ad17f3fddbe1f7e0 SHA512 fe000f7f78ed2ddc76c496368d7697bb36b0984d7d7d0729af9cb0fbec90e2d27eca777dd43d13f41a3f6b14b6a9fd735ebd777e30b6a6943f0af735f9ca9daa
diff --git a/dev-python/python-bugzilla/metadata.xml b/dev-python/python-bugzilla/metadata.xml
new file mode 100644
index 000000000000..91e83a14f889
--- /dev/null
+++ b/dev-python/python-bugzilla/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-bugzilla/python-bugzilla</remote-id>
+ <remote-id type="pypi">python-bugzilla</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
new file mode 100644
index 000000000000..745efac36a7d
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
new file mode 100644
index 000000000000..05c40aa71118
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage
+ dev-python/pep8
+ )
+"
+
+python_test() {
+ "${EPYTHON}" ./setup.py test
+}