summaryrefslogtreecommitdiff
path: root/dev-python/python-box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 11:39:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 11:39:43 +0100
commitc417025a2ab386cddabb71ad598a9b75b47af313 (patch)
tree65963e1f2e99ed22f278cdb819bb1d0892062731 /dev-python/python-box
parent49fadb6686800eac5ce039896df6437ac7240c8c (diff)
gentoo auto-resync : 30:09:2023 - 11:39:43
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/Manifest4
-rw-r--r--dev-python/python-box/python-box-7.0.1.ebuild52
-rw-r--r--dev-python/python-box/python-box-7.1.1.ebuild2
3 files changed, 2 insertions, 56 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index aef81b0cdfd9..513c9d6a16bf 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1,5 +1,3 @@
-DIST Box-7.0.1.gh.tar.gz 86746 BLAKE2B 33288c89d1b285d1c04ebb00d56a26d451f7b22eefbcef12219108975aa610054af67f69153436033a183c7b26cf216649ddc75b4354f2ff4f02f2a6fc2903bd SHA512 fe08fbca79fa02e53bc4208387162e49917f302e1595d924d4290d690092a9f7fae3f0cac66de1fd48ef16e627c4fbc2b2babed52b04381b24dab9b083040cf7
DIST Box-7.1.1.gh.tar.gz 87515 BLAKE2B 388944c3a577105ce1e12e9abff7da148d028db88d8070a09e6abe190882acdbfa4cf9d773af6cbae7e945603dc13d3d853253dc18b0d2d2b17c678293583b8a SHA512 60e44eda013a5ab1de2215d156caf2567a24b0471ee20e52096137ad761e92c3ca20d9f3967a21e38ac924488a2b76399c4ea1bc86b652dd72d7494ce22effee
-EBUILD python-box-7.0.1.ebuild 1102 BLAKE2B 1be5f98916a5bdcb0709b7c671c9bd28549aeaca9831f9eb33b06c94a29765d8f00843b8b7beaa44824ded175bb675a60858ee23d9f112929488cfbc8db103ad SHA512 e7bdfd202754c628a8b89cb506d98aca97408588c3931b405b25dd3d629387443a8a222dca2a2037afc76dc77ff3fc06554c31430540fd159f2e17038024342b
-EBUILD python-box-7.1.1.ebuild 1122 BLAKE2B 784cf3863b946885df1e9b09052a185f8167bded7b073b351a3c2510f599ada97745be20a54b8a9077671d71f0882f7144dd81f58efce3888ffbde09554fac20 SHA512 60da5b46cd66c2c36271af95a6f033ae91092b19ac321f722b4620071878aaffc79ce18ecd62b3e49401982c6e01516c5f1d3c5ebdad2008bc5e8de1f0d6248e
+EBUILD python-box-7.1.1.ebuild 1121 BLAKE2B 4b9bd63fac93125fb31f117794e2588dc6d453540729ad76bbba5facdeff48511818afabce730715870d9c9a71ac9f4f38a1ebba348dbd4352f43738057d45a2 SHA512 74f02a1c700af0836c534725fb993ed55ad9af4ae1b3f1864245c2a51dd4034f1bc16ab406625dd85f67d21bc8fdb142466ba88a18f6c6b6efd15483c07c7a39
MISC metadata.xml 610 BLAKE2B 7adbfb9b5d5fafa5e1b943fb3321d9b115586388c4480d3f27d1239b04391bae8a4551aee5b7109b1ee3d44e8f260cabf6ce4c42df4b99d8db9d3a258ce23466 SHA512 83bd215e4350c1d7a9ac4f36a485e7dbb4382b585634245d8fe4f6f31dcc2fbc8ab78488ccac6d7ffa693b8e261fe094de6808e10787cf73f169e6c3f83875f2
diff --git a/dev-python/python-box/python-box-7.0.1.ebuild b/dev-python/python-box/python-box-7.0.1.ebuild
deleted file mode 100644
index c300e79fa62f..000000000000
--- a/dev-python/python-box/python-box-7.0.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-MY_P=Box-${PV}
-DESCRIPTION="Python dictionaries with advanced dot notation access"
-HOMEPAGE="
- https://github.com/cdgriffith/Box/
- https://pypi.org/project/python-box/
-"
-SRC_URI="
- https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # looks like broken tests
- # https://github.com/cdgriffith/Box/issues/257
- test/test_box.py::TestBox::test_box_kwargs_should_not_be_included
- test/test_box.py::TestBox::test_box_namespace
- )
-
- rm -rf box || die
- epytest
-}
diff --git a/dev-python/python-box/python-box-7.1.1.ebuild b/dev-python/python-box/python-box-7.1.1.ebuild
index a71c7fcf6444..9229c71b3a4b 100644
--- a/dev-python/python-box/python-box-7.1.1.ebuild
+++ b/dev-python/python-box/python-box-7.1.1.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="+native-extensions"
RDEPEND="