summaryrefslogtreecommitdiff
path: root/dev-python/python-box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /dev-python/python-box
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/Manifest3
-rw-r--r--dev-python/python-box/metadata.xml16
-rw-r--r--dev-python/python-box/python-box-6.0.2-r1.ebuild25
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
new file mode 100644
index 000000000000..36139bc0a3dd
--- /dev/null
+++ b/dev-python/python-box/Manifest
@@ -0,0 +1,3 @@
+DIST python-box-6.0.2.gh.tar.gz 82454 BLAKE2B 2e29ae1fe62e588a4534b66dc4de53478b2a7a236c9ea43b8e3a3fa0985f75042b64d260ac0415a645fb3067bbb427fdb7d840b63260620d4754261a49237896 SHA512 9305f1e4b5694ac1bf3230a8f089ec7dce324272b6d11abc08aeaabf3e2c74f763170b23201139ea3368bc2682a893660376f2a9be0cdd4fc16827f04e7b6240
+EBUILD python-box-6.0.2-r1.ebuild 633 BLAKE2B 042cb9d5366c57ceaae1ebb2ba7109b2707ba3f9785586494af492b3d6397751f6ff18b668ed2944f228eb49d17a05dd1156316fa389fa9c533103f02028b463 SHA512 0754c642c85cd6527177f31ea616462e7b5c100d27737f2eb99efc9e583b8a63eff21900d88d7db06e8cd24551c690526850032aa53828202d5e6db0e43e0d9f
+MISC metadata.xml 526 BLAKE2B 9b7e9da39268190a4e2d34a6cbc4a9011e63ff916ddcc87fa0d799c3a48a71e67da0677ff41e3e2fa90e0167d91e4091f8a7d00bdcf804ea88321e9ea5a21d00 SHA512 4aaa21b74825ac744cc440cfcaabf68300f1f6035c64020ac6e4b967daf816a3dd36a770b6eddb925e32e8061227aecf6be61356873b2b4720025119e351e57d
diff --git a/dev-python/python-box/metadata.xml b/dev-python/python-box/metadata.xml
new file mode 100644
index 000000000000..c0dbbdd823f3
--- /dev/null
+++ b/dev-python/python-box/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cdgriffith/Box</remote-id>
+ <remote-id type="pypi">python-box</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-box/python-box-6.0.2-r1.ebuild b/dev-python/python-box/python-box-6.0.2-r1.ebuild
new file mode 100644
index 000000000000..4969a0bc8f0c
--- /dev/null
+++ b/dev-python/python-box/python-box-6.0.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="https://github.com/cdgriffith/Box"
+SRC_URI="https://github.com/cdgriffith/Box/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/Box-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest