summaryrefslogtreecommitdiff
path: root/dev-python/python-box
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /dev-python/python-box
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'dev-python/python-box')
-rw-r--r--dev-python/python-box/Manifest2
-rw-r--r--dev-python/python-box/python-box-7.2.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index 8d52a5e68b3c..e6b845b1d8f1 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1,3 +1,5 @@
DIST Box-7.1.1.gh.tar.gz 87515 BLAKE2B 388944c3a577105ce1e12e9abff7da148d028db88d8070a09e6abe190882acdbfa4cf9d773af6cbae7e945603dc13d3d853253dc18b0d2d2b17c678293583b8a SHA512 60e44eda013a5ab1de2215d156caf2567a24b0471ee20e52096137ad761e92c3ca20d9f3967a21e38ac924488a2b76399c4ea1bc86b652dd72d7494ce22effee
+DIST Box-7.2.0.gh.tar.gz 87699 BLAKE2B d6f033919e5451adfdcb0c14c28a47e25b619eb531280a39b68912179ad3a21638d4fadd6dbee2b09bc445b1adc2dd31e042d1e816dc5fc36098ea5eadab8a30 SHA512 8f2ec95a0539c8000d08353eccd66dd9de4049408b0cef9095f3bf98486424214e1d47ef5c408e425c5c2958652624efa512701138d91d51356f07795c508b9f
EBUILD python-box-7.1.1.ebuild 1121 BLAKE2B 4b9bd63fac93125fb31f117794e2588dc6d453540729ad76bbba5facdeff48511818afabce730715870d9c9a71ac9f4f38a1ebba348dbd4352f43738057d45a2 SHA512 74f02a1c700af0836c534725fb993ed55ad9af4ae1b3f1864245c2a51dd4034f1bc16ab406625dd85f67d21bc8fdb142466ba88a18f6c6b6efd15483c07c7a39
+EBUILD python-box-7.2.0.ebuild 1122 BLAKE2B f58c059d36b76842afd0c30ef6751912c4f17edf24faaab2f07368a7c4ec7cc4a77106f5bcf816fc524286aed2a5a2ef3804278934b6a7105c7317a7b330c323 SHA512 395433f4fd8e8431febfda3306062da9778fd74690d276c41cb46a0e3165309f340cdac9ce02e024181dc63ee56b57bf99d37873d9b54d49a1452fca772aef8a
MISC metadata.xml 455 BLAKE2B c87617c0445d56b0b2615ee0727bd18202ff2aacab347e0ddd6e26c2c4a7ea2ec484a01227c7a5a7deec870aae3475422ab4940b15b08401209936d004866c26 SHA512 3d4f528845543f82e21bd97cd4eeea8e52da76634832640a430fe1764f56442a9e909cf14a0426eb64ac64c77a93d619c03731678d0beeb758720261a374b45d
diff --git a/dev-python/python-box/python-box-7.2.0.ebuild b/dev-python/python-box/python-box-7.2.0.ebuild
new file mode 100644
index 000000000000..2fc0ece6b850
--- /dev/null
+++ b/dev-python/python-box/python-box-7.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=Box-${PV}
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="
+ https://github.com/cdgriffith/Box/
+ https://pypi.org/project/python-box/
+"
+SRC_URI="
+ https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+native-extensions"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use native-extensions; then
+ # a cheap hack, extensions are auto-disabled if Cython.Build
+ # is not importable
+ > Cython.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf box || die
+ epytest
+}