summaryrefslogtreecommitdiff
path: root/dev-python/python-box/python-box-6.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 21:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 21:04:03 +0000
commit34956175e774668656885552a9c94abab557e41c (patch)
tree43e9fd64c0e85eedaa28a99b8858ea3c344d8ff9 /dev-python/python-box/python-box-6.1.0.ebuild
parentc9388864702fdd7b0b56c049eddb41bdb9054dcb (diff)
gentoo auto-resync : 30:10:2022 - 21:04:03
Diffstat (limited to 'dev-python/python-box/python-box-6.1.0.ebuild')
-rw-r--r--dev-python/python-box/python-box-6.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-box/python-box-6.1.0.ebuild b/dev-python/python-box/python-box-6.1.0.ebuild
new file mode 100644
index 000000000000..b1f05d8d66c8
--- /dev/null
+++ b/dev-python/python-box/python-box-6.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=Box-${PV}
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="
+ https://github.com/cdgriffith/Box/
+ https://pypi.org/project/python-box/
+"
+SRC_URI="
+ https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest