summaryrefslogtreecommitdiff
path: root/dev-python/python-blazarclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/python-blazarclient
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/python-blazarclient')
-rw-r--r--dev-python/python-blazarclient/Manifest4
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-2.0.0.ebuild4
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild35
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/python-blazarclient/Manifest b/dev-python/python-blazarclient/Manifest
index 7cb52c0d2331..6bd9bc8c369a 100644
--- a/dev-python/python-blazarclient/Manifest
+++ b/dev-python/python-blazarclient/Manifest
@@ -1,3 +1,5 @@
DIST python-blazarclient-2.0.0.tar.gz 32078 BLAKE2B a8f7359485889d41c8e6a36f90f6279a366210d29e3080353fe32e6ee6929784c954c86f0e645d4cefe104132b557648ce27a59873a8248c68d02a0c954490c3 SHA512 af57b7a9d914ed216fe53f6e102ade25654fcf9cc0d4a422c912b2129f5905f47272ea959fab38f0ac23678e719c8b5807fa5e852b22f5f7418c72a17d25412a
-EBUILD python-blazarclient-2.0.0.ebuild 1110 BLAKE2B 0b0a31f987820ceacbea2d4222ba160ff0c7726e7fbfd1d951253e79f8e8c08914463be447d46b91e79bf402e4fa36c121cb10a77445855c40844bb4eac6c022 SHA512 5beda7502d04e74195c935bf1de61b45a009d799b66357e9397557e6ac2f7e6c7b842f2ce4a102ce91df42140bc33502b019c36efad7744afb149813196f9e51
+DIST python-blazarclient-2.1.0.tar.gz 32950 BLAKE2B cdad6f6e60e95ba97fff6a3d54e642679e2ba203d1aadcadb8190c9fda38dab27808ffbddcfa41852dc72504e9009ec62863991f832d086d70e22bf9652151b5 SHA512 a5d2749969d354ff96b4f223d49f69333a874f167e62663edf4209879b3783d1272dc591157b5a8d1b25206e7c796aa4e0d5966de74aac4429c2ebd9670d1987
+EBUILD python-blazarclient-2.0.0.ebuild 1097 BLAKE2B b952db5e7f825eb086b0f2c1904f72e48eeba5f7077cde1dc5767027f6e871f8d38f3a73f88d4ed370da174437b86e07c2261efac8ac9e89836b3ebdaf4168ff SHA512 a63303deb74aacde96fcae0cdab111a0e6522b89bc7f9e95f1aa2ace0d7e48af1449dc06162d5f377b708a52e6fe5cbe0af3ad9e3cc2179ca34d9bb5b55f0081
+EBUILD python-blazarclient-2.1.0.ebuild 1109 BLAKE2B 03343081fa521a8bc8c5bb6a5c9997eee0cf54944de244edcb307e230e629bc4e64dc1bdb5054461ba5f58dc7b6a5d7bd52176e79072ab6cedf8f8ea1df8f721 SHA512 03631bfc46fae8e8f61fc9bd8bb2c301a38be581563d5c0b8977f388be0e231ff784f7f0fc139146e94d8b218c7b0e3b1a42b943a99e65c104df6355746d8ac9
MISC metadata.xml 431 BLAKE2B 360c1bd7ad09d6c8ef45bab793e3b7514de1460df7eb22fe086584940812cecfb4a626ea975de1921234de7a5c151915fb80404c9ac42ba839fd8e87e1d45ea2 SHA512 2bf14d8fa014027952f8767e00ee336955fc1ce0c16979f825f1b3be7e060a2ee4f7becfaf14e885f5f08da896dc8faa15aaab797ebb522f74db7f4768f2875e
diff --git a/dev-python/python-blazarclient/python-blazarclient-2.0.0.ebuild b/dev-python/python-blazarclient/python-blazarclient-2.0.0.ebuild
index befdd60a0836..dd57a02422ac 100644
--- a/dev-python/python-blazarclient/python-blazarclient-2.0.0.ebuild
+++ b/dev-python/python-blazarclient/python-blazarclient-2.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
inherit distutils-r1
DESCRIPTION="This is a client for the OpenStack Blazar API"
diff --git a/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
new file mode 100644
index 000000000000..0b2c42972f47
--- /dev/null
+++ b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Blazar API"
+HOMEPAGE="https://github.com/openstack/python-blazarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+"