summaryrefslogtreecommitdiff
path: root/dev-python/python-backoff/python-backoff-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/python-backoff/python-backoff-1.10.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/python-backoff/python-backoff-1.10.0.ebuild')
-rw-r--r--dev-python/python-backoff/python-backoff-1.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-backoff/python-backoff-1.10.0.ebuild b/dev-python/python-backoff/python-backoff-1.10.0.ebuild
new file mode 100644
index 000000000000..29639f91e18c
--- /dev/null
+++ b/dev-python/python-backoff/python-backoff-1.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+MY_PN=${PN#python-}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Function decoration for backoff and retry"
+HOMEPAGE="https://github.com/litl/backoff https://pypi.org/project/backoff/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README.rst )
+
+python_test() {
+ emake test
+}