summaryrefslogtreecommitdiff
path: root/dev-python/python-augeas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/python-augeas
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/python-augeas')
-rw-r--r--dev-python/python-augeas/Manifest1
-rw-r--r--dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-augeas/Manifest b/dev-python/python-augeas/Manifest
index 188b92a244a7..ab060596a949 100644
--- a/dev-python/python-augeas/Manifest
+++ b/dev-python/python-augeas/Manifest
@@ -1,4 +1,5 @@
AUX remove-tests.patch 417 BLAKE2B e3a0e4b3fdb42b395fa336461f84feea4dac252399ff266231121a48e659fbfad671d318e9a3212f77939f7e609b3df71363abf8f9f2450e087479869731720a SHA512 3b399e3e85cf12bc5ee2db3d53594b2eee5ba8809bfaa950738730194c2dab16c8b776100b009bdbb520020b0ae276c8b13291139dcb1d48e0887bec72c80679
DIST python-augeas-1.1.0.tar.gz 93657 BLAKE2B 21d2713d8e11552cc7f0191d2b8f7805b223f5dc9478b89b39dcbd325ab354cef0bfc0314852dc2b071b3b061319b4e27904c0514eb6d6ffd4e39cf7ca33d1f9 SHA512 34e4e98219b9146ef843d94c2e854e951a9b7e81409e603e77e7defdbb8765c013a2c869a4f5db2244352ca35656e18667a0210dd24099cb3e4552a04b23aef8
+EBUILD python-augeas-1.1.0-r1.ebuild 626 BLAKE2B 67f185c715cd68c2df3049c9760e8cf02e258093a55250c3753f9ae9c5fcc65637ed1adb5756ccfa1cafa943afcf7e9e1d0fdafafd6dcc5ec63d335994e0e1d1 SHA512 e691cb4247c4dc8050a6cbd653187ded7a329aa49410c6d71975a5e14cd9649abe6e22f3bd244285f22f87ac54cd1c0a47e4200c26f777479155797521253c19
EBUILD python-augeas-1.1.0.ebuild 593 BLAKE2B a281c1c4a107ddacbd8d96f1d954a0979a3e5e27f6c358f978d6388fe5ad66787b56e304aea783458c8edbd2b6304190a466a0fea1155d779264bb56906cdf23 SHA512 2699f316a8cba901bc5acb03e3270602a8624c2339b0da81abbb0a9c1a2e8f54788d28775b2a1d9073d83a8c5810f76483a6cc9a077ed29a0b2ffb7699ca1d1c
MISC metadata.xml 423 BLAKE2B 0caa39c52d7e83a0955531808d9bc2abb0ca3d5a1d81d0c1258d209debed472e55c96f93f6e6474beef75ce6b0691195c0b1092154eb463ffdb4190b4c59f0fc SHA512 53e90a9adbf82e9e3f7671b7de404fa4e32050aa9316b226efd782ad49628eeb3a407d6ad45a71bce698eafd60ac3bb46b6289df094fccfd2196d9d33ae290a2
diff --git a/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..47cf09eb8435
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/remove-tests.patch" )
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" test_augeas.py || die "Tests failed with ${EPYTHON}"
+}