summaryrefslogtreecommitdiff
path: root/dev-python/python-augeas/python-augeas-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-python/python-augeas/python-augeas-1.0.3.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-python/python-augeas/python-augeas-1.0.3.ebuild')
-rw-r--r--dev-python/python-augeas/python-augeas-1.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-augeas/python-augeas-1.0.3.ebuild b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
new file mode 100644
index 000000000000..10b466c7506f
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd test && "${PYTHON}" test_augeas.py || die
+}