summaryrefslogtreecommitdiff
path: root/dev-python/pytest_jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /dev-python/pytest_jupyter
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'dev-python/pytest_jupyter')
-rw-r--r--dev-python/pytest_jupyter/Manifest3
-rw-r--r--dev-python/pytest_jupyter/metadata.xml17
-rw-r--r--dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild31
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest_jupyter/Manifest b/dev-python/pytest_jupyter/Manifest
new file mode 100644
index 000000000000..c3d16da78559
--- /dev/null
+++ b/dev-python/pytest_jupyter/Manifest
@@ -0,0 +1,3 @@
+DIST pytest_jupyter-0.6.2.tar.gz 15174 BLAKE2B b6c536383ab1b8e375e4250b4922ac6372f850ee4993643122896092109d3f711f91ccc7b159b7330de18f7876df818dc01d31c05e3c18d97488255e063db4d4 SHA512 396f7a7c978097e6dee37ead92bb3c8cef2a8100a7cc85b0b1eab19e20bdaed3332391c17568a6a279ab6ddeea1fbb2fa8dafe24ba4500982ba52cfcda2b1052
+EBUILD pytest_jupyter-0.6.2.ebuild 729 BLAKE2B 69c27ae1fc34108a0a36310d703ecfdb472b0b17b395d6d5264ecdc0aa021bc9f5ef4ff6725a45b53f19f8ffee5a7ea65284f7b815d227b9183cd45df34197ea SHA512 add7f9be5035d57e78f2a063863893436fe5d3cecc532ec985d15551cdabd2b33db66a409a324ad7eb97016ef1d8f295d28484009f63296eb3a5b9a859a29e0e
+MISC metadata.xml 544 BLAKE2B 2774989bbb5ea75c4254ec2c9f3daf04a48bdec28698d62afd2471abb4031273bea581c09151efa643fc691a3fda2e1a4211dca66882fe2c5a24d7a6bef7c1a1 SHA512 e3751515a8baf2b422cb680870adbe9393d37ecf2e8b01212bcfa7d0b62ca368c34a9140945e1af4d7c7f0c5443b996ac7cbd4394833aa13b4e937b05bfe0e6b
diff --git a/dev-python/pytest_jupyter/metadata.xml b/dev-python/pytest_jupyter/metadata.xml
new file mode 100644
index 000000000000..8d9f695ec9a1
--- /dev/null
+++ b/dev-python/pytest_jupyter/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-jupyter</remote-id>
+ <remote-id type="github">jupyter-server/pytest-jupyter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild b/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild
new file mode 100644
index 000000000000..78d14293f4a7
--- /dev/null
+++ b/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest