summaryrefslogtreecommitdiff
path: root/dev-python/pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /dev-python/pytest
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-2.7.2.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index f2f5bde87fbe..4a0fb88c933b 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,7 +1,5 @@
-DIST pytest-2.7.2.tar.gz 532836 BLAKE2B abdb179ca82078ecf081055484d7fc1f1d63f7f3ce58b19ed27e10da25e163a24ad89e4afe8b7e5af0d5fa14ace6eb18c6dbe302845fb6bbf0a545a443fc7847 SHA512 5474a4fe58437a4971fb21b1b37dad3c08e18e5d154931ff23e597f881100a3515bf0cf71d06b143465594ad2a91a96f84f4836d84c39691143c8d88ca7a4360
DIST pytest-3.0.3.tar.gz 731934 BLAKE2B 7fb57d75bd54eb8a31d9701fdf739119715c475eaaacae3cd038057c1d2bf43fa86ccdc45b3c84962708ef606976ab39ad41e0c3690c8b5f4c04d870579a384e SHA512 ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af
DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
-EBUILD pytest-2.7.2.ebuild 1889 BLAKE2B bb4200ec7f71244afe1ad7fa37d2672ddc4533de2b208f86edd4f1ee26c59586fd6ed642771a7e10afa72d06d45006bb334f67bd3473a6eaaaa31732021b7140 SHA512 696c2aeb44dea0987c1732331bbb90703aee1b3b4a918ca198e1f68e0d7dfa509bdefc26bb80df8b0af2f2412126eef2db96e3d63701552a261cfc367a064c4c
EBUILD pytest-3.0.3.ebuild 1962 BLAKE2B aa795a89cae68897eb2ebecb511240a456cb14c2c09aa05f28483af496cec60c5a0383909336c0e3da1ee05ab1c34a1e3ea261539bc0499f9026d04942ad9a66 SHA512 daf2483c38abd8fa13fcd1a86d8e5f6c1e9ecf8b551fb12a1f2a45cb77cd2a8c9c820cf42f964e31ab03c9ef8a0f59dff332ea84000b9c35f4dcfc7f86165d64
EBUILD pytest-3.2.2.ebuild 2091 BLAKE2B 75f73763ecd35f76eebbbe3a6bbdd1fe61161bc65ac8db6d8aa19ba47ebdea8cd81907b100152d83da16353787ce83df573e016435f2980dcca652fde186b59e SHA512 2cf8176362bfacec42cfa581ef1036951c2b45eb4eb77f8a68f227aa3914a71c14a8e80a9d1f1f19f9d00afc3227322dee1e2c9970a82de435d1516555f0183b
MISC metadata.xml 309 BLAKE2B f29391c5f96f44f6329d3665346a5d46ecb4a86d103ae8008769af86126756e76bfa89cfe462e9c219e5f70b64013f662d020c7a2f6015d8cadd0eb25a7614eb SHA512 ba53c13ac716488e3e5dadf5dcfcb697dc9bb13f89e9d0fb98b9a5a6e36cafeeb64d1348008f42497117bf46fb6f3bc288c10a68c4d5ab53c9c02a3ae61b594f
diff --git a/dev-python/pytest/pytest-2.7.2.ebuild b/dev-python/pytest/pytest-2.7.2.ebuild
deleted file mode 100644
index ce6683f5f930..000000000000
--- a/dev-python/pytest/pytest-2.7.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.29"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Prevent un-needed d'loading
- sed -e "s/'sphinx.ext.intersphinx', //" -i doc/en/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- # test_nose.py not written to suit py3.2 in pypy3
- if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- --ignore=testing/test_nose.py \
- || die "tests failed with ${EPYTHON}"
- else
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
- || die "tests failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
- distutils-r1_python_install_all
-}