summaryrefslogtreecommitdiff
path: root/dev-python/pytest/pytest-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/pytest/pytest-3.2.2.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/pytest/pytest-3.2.2.ebuild')
-rw-r--r--dev-python/pytest/pytest-3.2.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/pytest/pytest-3.2.2.ebuild b/dev-python/pytest/pytest-3.2.2.ebuild
index 1bead6e09096..a8ed90ecf524 100644
--- a/dev-python/pytest/pytest-3.2.2.ebuild
+++ b/dev-python/pytest/pytest-3.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~amd64-fbsd"
IUSE="doc test"
# When bumping, please check setup.py for the proper py version
@@ -24,8 +24,8 @@ COMMON_DEPEND="
doc? (
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
+ )"
+
DEPEND="${COMMON_DEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
@@ -34,11 +34,11 @@ DEPEND="${COMMON_DEPEND}
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}
- !<dev-python/logilab-common-1.3.0
-"
+ )"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ !<dev-python/logilab-common-1.3.0"
python_prepare_all() {
chmod o-w *egg*/* || die