summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 05:36:05 +0100
commit4bbcd26e7cb1908fb98bb318bfaa13ea9e32d860 (patch)
tree39e9258a61ef296b0e5afba0c7dc2557891487c4 /dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
parent47d5e233005d470dbd431a280e64ce6073fc7149 (diff)
gentoo auto-resync : 10:04:2023 - 05:36:05
Diffstat (limited to 'dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
index ed4dc6f4834e..b3c16258b82c 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r2.ebuild
@@ -3,27 +3,26 @@
EAPI=8
-PYTHON_REQ_USE="tk"
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 pypi
-DESCRIPTION="A pytest plugin to run Xvfb for tests"
+DESCRIPTION="Pytest plugin to run Xvfb for tests"
HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
-SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
RDEPEND="
- >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
- >=dev-python/pyvirtualdisplay-1.3[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]
-"
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]"
distutils_enable_tests pytest
python_test() {
- epytest -p xvfb
+ epytest -p xvfb --runpytest=subprocess
}