summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-28 07:18:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-28 07:18:56 +0000
commitc1cdf388025eed22cca32ace0115377d0026e712 (patch)
tree1394fe10d5d45bbeab0b74635f75068fe1345c02 /dev-python/pytest-xprocess
parent6607d04e823c033d8e5910e4c9104771ca534b12 (diff)
gentoo auto-resync : 28:11:2022 - 07:18:56
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest2
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 83acd1d99fb3..742d38c31d9b 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xprocess-0.20.0.tar.gz 30342 BLAKE2B 8e66ad321224cb8e702721b0936c56b65be5aee9330a233c710519303679f2d1eea03825fe4326ffd2811f6fe4c37db217a2c0c34561742bd2c849ddcae7284e SHA512 bce022c924db94f53549c1df5547a8df7390806bb99d817f152f1e5fb946fef60f2447a31dc519577c1b54d6a7adeb7d7d996a28e7784918622db5ccfd0b035b
+DIST pytest-xprocess-0.21.0.tar.gz 30601 BLAKE2B c487b6223306c8a96ea2c4f99763ab8e59ea1db908b2ed93280fa3e2805794798b4555c3d07c730f911702712371bb390780709caa9eb6663451367f58b9781c SHA512 72f8db45a11cffb65302379c1690ef5ad9d71a1aa40b7fd03e1231f7ad0c0413638f7d2155f5b366d2d623399512759d8ffdac8591eb24b77562f9b1f584ed74
EBUILD pytest-xprocess-0.20.0.ebuild 684 BLAKE2B 7cab7b699749b1bc2d35f015852cc31304374a497c7d861bff383ea46111467c4613b3810d1f48081a85ab647218c77d568bd30b15712c9920a59682898c6637 SHA512 aa84967b3bed18718f978f8e090d9ca92ba47416197d241ccd4e9f5610a0cc1c3cb9a2fcdde47c43a4ca4fc5681d4508def33769b9ab46e9770190f677b88a6d
+EBUILD pytest-xprocess-0.21.0.ebuild 725 BLAKE2B 6497a0985b87d867292ec7cb0b9eea38868907f9b0759d92f3035d871c4e2d3caf311a63b46e611fd33d31261746ad6119c0093605959cec897f45bab7971ae5 SHA512 4a31b0f3ca67705332e168e886e5bcc537b60e6bec40122c7d2b57c8adbf9c8c9d1fd4e5aa93ea09cf20faddf6416f80b4bad8c50c3a9f20ad55b0d72656ba32
MISC metadata.xml 422 BLAKE2B fb18d498d2325613b4ddb9262d90108aca85cc28c4dc298359adc0cb589565df894b5c48bfdc7a7f83cf30421f324fa1af93333ae20fc793910993e0a93db90b SHA512 19e96fb0695284d9adfd71eccee8f3ab0661d5e0231f3f55db0456a3dfe797fb683985cb776e45a183a710462e990f539f75a764dca68d0c2e631abf68d8344e
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild
new file mode 100644
index 000000000000..07a1ee622918
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest