summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-xprocess
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest3
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.18.1-r1.ebuild27
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild4
3 files changed, 31 insertions, 3 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 1fec718f1e00..12d16834fc89 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xprocess-0.18.1.tar.gz 26976 BLAKE2B 9772fff488414406f487add01fba9ee2e10e12965d5b289b8c17cffb5a6566aaea0653ca1b390e6b4c70d79ce3698b0ce8122ed919f9778cb8cf3f7488cffc8d SHA512 f19cba9954e4b2363db13b7dba373f5e50cfca6f43d6455f271bff4d01dcc2a3b15c13a47076dbeed34feffee856a8271df4837edab413e964a848cbb6228e7e
-EBUILD pytest-xprocess-0.18.1.ebuild 639 BLAKE2B 7cfd8906ab46f7ecd7c0d5d7e9ea86dbcb14a56a572953c5b051e5e318a7d47db5e8f8321ad49ee238175415fbd26ede833a44684ae753e88fdc50f47a773fc2 SHA512 2883d5733f962dd8bdfea5b61c831106b7acc1eeb167fe5b8a1d02d0e386c39e2a2b5e94de7acdc7dec8c20e8e860ff24ab67a69aedb887c9aff2b5708585d9b
+EBUILD pytest-xprocess-0.18.1-r1.ebuild 692 BLAKE2B b1087f9caebbbcf415e745d5ef3e821f1a81b725c4b5f28233da1644c59374f04a9e0c4c4cdbd9c352301f14af7f7ff2f51015c97d0d056abbe2abffc56ea221 SHA512 257135c87f8ba7b2bf930dea4184d1de6129f8bbc00ab0e3063377a9be5163f87a34bd82026b034ab75000cab5438e3e55db5a3daadf90fe1dbe5aeae0d1daf4
+EBUILD pytest-xprocess-0.18.1.ebuild 646 BLAKE2B ee2fbcdf76fa7e80f8d51c004ffcbae62abdb6a03a87db882fa44c32b2047c8334dea7832abd9f487b2f22bdb8b3b92bed4cb6d1bf8ab0b26fe122addef49272 SHA512 5ecc54438b985faf8e21a79bc62719830fa82f5b5c650bda8df734214311d1288c2fb73e266bfef6d6d86feb850cd6b6dc09edecb3ab15d3afe06ea7d9a107ed
MISC metadata.xml 422 BLAKE2B fb18d498d2325613b4ddb9262d90108aca85cc28c4dc298359adc0cb589565df894b5c48bfdc7a7f83cf30421f324fa1af93333ae20fc793910993e0a93db90b SHA512 19e96fb0695284d9adfd71eccee8f3ab0661d5e0231f3f55db0456a3dfe797fb683985cb776e45a183a710462e990f539f75a764dca68d0c2e631abf68d8344e
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.18.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1-r1.ebuild
new file mode 100644
index 000000000000..ad5324f444dd
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
index 2766e61af2dd..05ea0dad22cf 100644
--- a/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.18.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]