summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/pytest-xprocess
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 575a50bf96de..d2640b032b44 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xprocess-0.12.1.tar.gz 12078 BLAKE2B 30c3c2b41e79b79c5a18911c325ff273b80c45f29d269b96c4085c0c78a6897b2064eb1d2e83f9c061c4663d2f52d88230d9e87ea2ba4d114c6e04f42aa50a5e SHA512 fda868a12a056070afd5838c4bc466b4906a7138f685d4a0e6e0adbd975e5a1a2b9b37b8de36a45fb700e02ca14ae219cfe29c467f8d03e55d2a375a7efc9927
+EBUILD pytest-xprocess-0.12.1-r1.ebuild 833 BLAKE2B 0d1e39254d2c6c3efcf4283b0d954e1f832acbbd2aa0cb3d1923945ae7c9e79a3c7bdde2f425e1c0710a18292ccae3298d412676ebc6c8e86497b7bb62f158b7 SHA512 d197bd9afc5ff642674b8367fe1f43ec417c1124c00fef127cb3746663cbca416575eca9bd68597a569ab8cff13131ee74b636657481f7343b496b0f8dae50b9
EBUILD pytest-xprocess-0.12.1.ebuild 847 BLAKE2B f18eedb3ef9a84a9ceb010f3cbfe89f866b9208a41b3c0a43372b26171e2cfe71a01b4be922ccf2a1f1bb8259cd68caf446b1c0b319aa47818340052473cb51f SHA512 f461f507470162adca23eb09004380262af6745a72c61de75575da679bd96d4eb6a472aa947f5204235ea693a9a353366d985f28cd583666acb4de644252c7e7
MISC metadata.xml 399 BLAKE2B 04dadaab28761796767c7a588294f6a8ea34cd665a4ca6b26dad8155432e12619f7d7825265df05d1457dc1c09265c1064efaa8280487d8eba60f1629798c648 SHA512 ae6d3628465eac8e46b14f8bb00a46884f07e85dc3246c3f3c1c6a85e178c7eab35511e583d08cb3b036f5ac28c8393dac90cf470ffb371a74cfd883a5978830
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..8677f37ccd25
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ cd example || die
+ # Upstream's package mistakenly includes __pycache__ directory that make
+ # tests fail.
+ rm -rf __pycache__ || die
+ pytest -v || die
+}