summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
commit29efd7db303b443e103311cc0e458ee5c134e8e5 (patch)
treecb6e3ef15df82575a93cae8bd11b635d473f3796 /dev-python/pytest-xprocess
parent19a808581ca18addf4b12d09f7e440b7244679e5 (diff)
gentoo auto-resync : 06:01:2023 - 12:11:06
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest2
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index bce77610ae36..b4453e41e77a 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xprocess-0.21.0.tar.gz 30601 BLAKE2B c487b6223306c8a96ea2c4f99763ab8e59ea1db908b2ed93280fa3e2805794798b4555c3d07c730f911702712371bb390780709caa9eb6663451367f58b9781c SHA512 72f8db45a11cffb65302379c1690ef5ad9d71a1aa40b7fd03e1231f7ad0c0413638f7d2155f5b366d2d623399512759d8ffdac8591eb24b77562f9b1f584ed74
+DIST pytest-xprocess-0.22.2.tar.gz 31346 BLAKE2B 07b9fdfea2ecd3d3aaf4115c2f7ecd41c864b4490694cedc54460d0f16397ebdda0ac88fd9bd1613dcaec1cb9c36571b8ab2febc8d151f8f6c4e19fe3abd0821 SHA512 2051be110dfda8063c31bb9555bff569f5d7a1332a62f8ce57fd799dfc7d8551ba1227df12f44fccc1ec62d9fcc0face104a77c9c5cc1abb583b74cd1d8a9ff7
EBUILD pytest-xprocess-0.21.0.ebuild 717 BLAKE2B c6a4e981ec827de573fd0396d57ffde4aab011815b0522692dacce1d9f8e7e01e87967cdbdbf023e2700061db593817e8b4b8ce29a6736863332c3f3ac6d3e1f SHA512 8788aa7661ab715c4a927e9355a4a75617e4bfde2cddaa79500bf69238c0c6720aec65bf5d9900a3194d26cb1b9ea947604e3a54acca975371a0cd2bce4a6d27
+EBUILD pytest-xprocess-0.22.2.ebuild 725 BLAKE2B db5313350c987164194a2e5edac5e56aa7f90606bddfb9df9b1f8f4e4a388df9ed8cfbde94d7459e66e9ba6ab60c85010bac83046088d7cb2a24fce99b056f56 SHA512 622f27875fb5cac62615b549b24da2f2513386eb064839f4582af9aa949cb36cf0ea39fdb63b4c92a694291e405120d54082a1417f47048168e046d52d6df905
MISC metadata.xml 422 BLAKE2B fb18d498d2325613b4ddb9262d90108aca85cc28c4dc298359adc0cb589565df894b5c48bfdc7a7f83cf30421f324fa1af93333ae20fc793910993e0a93db90b SHA512 19e96fb0695284d9adfd71eccee8f3ab0661d5e0231f3f55db0456a3dfe797fb683985cb776e45a183a710462e990f539f75a764dca68d0c2e631abf68d8344e
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild
new file mode 100644
index 000000000000..f275eaaf7297
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.22.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest