summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /dev-python/pytest-xdist
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.6.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 6c8e5dc971fd..1c8ba2a54765 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xdist-3.5.0.tar.gz 78977 BLAKE2B 94feaa236728688a993ed89825f4ccd67abd7a520d235790bbfc629173e5918695ac500d04de642f07d323325972512e3ad95f0ae18a9ea239da8c2f167ab1a5 SHA512 1b6a896c6c69c110d1f3aa634740ffced570bbb788b3474687fef20147a5480a8681886b04db0413f7db68db546236f9a7f37e1592a74d1145f6eb6d876216ca
+DIST pytest_xdist-3.6.0.tar.gz 83818 BLAKE2B e15935799675014a01524b850106c29b1e43efcdc965c5695ae727ba4c12af446dbaec662eb66022b3e553e311d456859e90c7cfb0f7b4d9d0f28c3184e2901a SHA512 d623d31fa3f441c7ac56b7740bdd205933b90c9784ae1bcbac185bdc2920f1a27fa51fa6e1b75392a3ae13a62c51e168925ce3040cc1f0d22e8d9906faebbc2e
EBUILD pytest-xdist-3.5.0.ebuild 1075 BLAKE2B a945b3f50cf62516ee10c6d088d4b0901bde616dc2a38a5101168f681aed0ea7483c0cd2c467b97b4c6b4a715b2f1e7830eadaff5049e7c53601ee6c0520f375 SHA512 7874e9babeb199127e7cdb4bf0c2dbabe17e93d8baa736bab52f9ed8f22cf50f65aee51f7917965559500eba17bae6cdab75ae5ecb877a68c24c7a97af6be9c9
+EBUILD pytest-xdist-3.6.0.ebuild 1069 BLAKE2B 5f669c4866dec982204c71633a494871bfdf29bc478ebdccc57f3f15e31f34b6a89dc1818d5f75cb6f98d3d9688550c902e21daaf7a07d0e3d923d00d925e6a0 SHA512 0f9584e958ccf7a93791a1da5e05c57b571859c5e2a3b9eea9364fa6de182005d7451cffecb29e3043586ab8a2d88d29751d46458c9cf3f673313e1d7d1dd263
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.6.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.6.0.ebuild
new file mode 100644
index 000000000000..602cb721af56
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/execnet-2.1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail
+
+ epytest -o tmp_path_retention_count=1
+}