summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/pytest-xdist
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index f18d83d1fd6c..36cb255aeea9 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,4 +1,6 @@
AUX pytest-xdist-2.2.0-services-conflict.patch 1097 BLAKE2B edc3ecb79578f89e9ce5515e194dc16df34abc2685d9fb78cc5930f29893dbd9e145c95e5b1f58bf252710c57964ea00dc8b71e20fd0aa713e9b9ab2d8d29a93 SHA512 50155aa39d0a87be7a22d0ccf6c9d8eacc8ce4342baa3fd67839b3c5b4d05b31fef5786a60e15051de3000b3ee3494ddb48feba43850d677484e239ee4be8b02
DIST pytest-xdist-2.3.0.tar.gz 66072 BLAKE2B 367ff15cd46b8594668ccd9710a2fc7665295d41e268b464b81d5e740a580d70621a1ab5ab590788e44887b7aa3049a83853ea097c0cff54e22c3422c8f11b24 SHA512 bf49a1684b29f0ae21621b9d293f530cf2fa3d88b33f631fb803aef872c0d5ef6b3bbf2e16d01be8a6c1872fe3e6cff86ab842e3000b9e642fb46c2a170627f6
+DIST pytest-xdist-2.4.0.tar.gz 67199 BLAKE2B bba867bfbd1e161ada2157fdb5a10f929fefed959b64afef74453206d91e5014abaaa1363ac9adbc89ed476a841607f6830781817842b9be119a09bda7278b91 SHA512 2d2da6aaa8da07a28d7c6c81a0044493b7d0d1a68921e7ec94cfd2f698eaa5594b6da4d82524804637d5cc061fbe19034f3c65a07ee5a0c906170856edc3d383
EBUILD pytest-xdist-2.3.0.ebuild 930 BLAKE2B 6a6d05f009e539a9bce4749c6cd6cb3de3414470f47654c15b11cccecb319bd60a11ccbd755f5699f1c0124c860bd887e3d38d0053992a5d5b28a2dc553be144 SHA512 6629403b5e92ac75b51ba53453e51d0c2e2e22c89e99cd6e686610857cffcccea92593729a0d16f5e1450141a8b0f18c1c20295bb509594e9b3c17622d42f9eb
+EBUILD pytest-xdist-2.4.0.ebuild 1166 BLAKE2B 44c93dac1e0cdc5a46243f236f223a68aa2ccd3e285743130448a175dca80fefbad0683b1087f66990ed36bce2ae174cc0d27cc6f208b17627731737669d63be SHA512 dab48191ac867caff2c55d2ef1f566ef767baa1c5e166c0403107f92274ae76af07d559ac5f8de162c6f645a487597cd0756af6b052ef25f43c5d22b5df60963
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
new file mode 100644
index 000000000000..a3f40e53e852
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ distutils_install_for_testing
+ epytest
+}