summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-xdist
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest3
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild45
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild2
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 3baa8d18a1c8..ad3264a1d6a5 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xdist-2.5.0.tar.gz 72455 BLAKE2B 4d7427e8a7d85d7b0dcae2697fae0f51913a3a2414fabbb192a8e3938431f5f121677dd43adecfb1fc7f3dd6feb94901e28b0a96787a2c2eadc1504aac55068f SHA512 22da4db7cdd6173fb8377b6adc30b5617ccb0bb308cb5d30980484dd7ddff87cf2a485ae8522c7957d8954dd2f8a5542b9f63b0fa7184cc44e50dbafc3f4e909
-EBUILD pytest-xdist-2.5.0.ebuild 1162 BLAKE2B e759800b95073ef2adcf0e65f6e2adaf4e2b763f647131048f87203568440d8cf1120d9c73dc1b009c48f9c4668291587838a51d6cd26c7c4b4ff53e91e68eb4 SHA512 f84daed8092f781ffec31c7e8ad6283ef6934034b9d5721a19848bb1e184123e03993e7c5a380d11773a2751f3d74cbb9f33deefa5aa55aa402fa85d9c786529
+EBUILD pytest-xdist-2.5.0-r1.ebuild 1131 BLAKE2B c7d846c8e378993ae77dd0f67264658ce09f748ae45eb0504afca76b0ef9bb4e91760ec4dd7c57ae4e55828b6e72941ac56ccd620a9528c115f4bc39bc7e81e8 SHA512 53dfa89a39676e42a3db1cdf785e45dba00cf8bd842f09a65fb67e8ed2f19e6bbb42061eaed90efe9ca49ff2e5da65a289e19f5fa427e4894b7c33cb147684c1
+EBUILD pytest-xdist-2.5.0.ebuild 1169 BLAKE2B 37d48c5b36ef3b530b0015a361124268492dc64ca4c53f4598a6dd8394976cf65239e76cb274423af96d6c78b710805cd1ec937f104fbd2f58aad69a4ada69c4 SHA512 c43b96c8f84c528ac2f847fafae6f15a6afcdfb2d12c15db6fa6037409eea3c909e738e176d849bf4374f44aec496990a4452cc43b970ccf4361bb211bf5566e
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..1079a190886e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.5.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
index d1cc99c0a7ff..7e1cfa8213b4 100644
--- a/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-2.5.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
# pytest-xdist >= 2 fails with pytest < 6
RDEPEND="