summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 11:51:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 11:51:16 +0100
commit74bdea52f57b5c6ac79078bc30a1c342dc3d49c7 (patch)
tree7d239372a4ee9d7aa7483f3ff0474ec2d64c426a /dev-python/pytest-xdist
parent4b718beb7d5fd4e0b5d741ff3a4c5c570519195e (diff)
gentoo auto-resync : 13:05:2023 - 11:51:15
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 2b15caf4b606..c72fa935cd0d 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xdist-3.2.1.tar.gz 76362 BLAKE2B a5cea5bab1176554bd0d1ebfff5400f60bd43964ae13c7f77ad77fc257db32ba0a0d6f2f3ec16211e48852a6bfd02a0949d618c7f2f6a8da11dd2843d88565a4 SHA512 ea42bea8b4df3d77ef680cba81f76f9f79d0ffcaad6f5f879cc82c53203d36ffe26f233dd6c5d1cbea22b43d257f0f4e6be793116bb281956316c44fc412f9b7
+DIST pytest-xdist-3.3.0.tar.gz 77580 BLAKE2B 5d983fd9c825b76d666a4de36087441a42e32ef11171d2fb4f8dde1f062fda2e664eb766af62012c977b5804f059eb9415fe70030d8a6ffc627833d8e69f1a02 SHA512 15cdfb3db409147fc5107d58bc8e2177a9351d2fde2486523ba17f77754083b75decafe442d5849d1be159a2eb9c20f6c3ec11a8c4cf16ac22d4e98a1f9de452
EBUILD pytest-xdist-3.2.1.ebuild 1096 BLAKE2B b42416c7d6da43b546ced93b46208b071688358cf3a201c5d9fd0689d5a6189c139842fd11c47a6226c26ac6f07752392c59239ace24b89676603bc45e1eddfa SHA512 239d131fdf0d4c7d68d522ca10b77ae3626421d4da5923fb12bc8998ab1b92e2fcacaa26617030bbd4aac2adfd33fc481c919c0f55175a22541cfe9ae423e935
+EBUILD pytest-xdist-3.3.0.ebuild 1104 BLAKE2B 18604032d8eeb812e4a005794eaeed43a3ac6433df75f877cae01929306eeed51abb17f55dbfa079c759f34463cbcbcb43fb0851328e1c24136594c314d0aa8e SHA512 22094bc669a552acd1677e16e398db1d64bb57f6b82a826b3ddff86edeaeebdd9de53ec787baeaf8d1125d676e53c4d98fc6b5c083b3e327aa41171a5738dc62
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild
new file mode 100644
index 000000000000..c3bc7d37a95e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}