summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-11 22:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-11 22:34:01 +0000
commit55d85b00f95c52ff327d35d9cc5bf240ab37f11f (patch)
tree20c24154d7233e2953d7f71952d15d62f6761e55 /dev-python/pytest-xdist
parent9990da9e2db6d5094701a2f4035e781826eff014 (diff)
gentoo auto-resync : 11:11:2023 - 22:34:00
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 18f29b982707..7f60e52b801e 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xdist-3.3.1.tar.gz 77751 BLAKE2B 483774b3fefefb513cc3021c49fd816089869a885ba098588e503530ff3b2dfb77612aff80a7147ff33fd8c1fe69c4fda40133de94007e41c699ad763d112e92 SHA512 f439ff1acf65a8df025fec847602ebdc5355b2099501845f8cde3c5287299a9c3102fa6dd6fc82a30bc016893556a24b0b5409323f5db4015e77c711a7b5c59f
+DIST pytest-xdist-3.4.0.tar.gz 78703 BLAKE2B a49dfcc707b4cc258c7cc26aa53f9b6b933880e55754a87f6de0fe5ca9b37cf7c5c5b52c3f04d5ad98857c3988130729510034dc3249c3c39bccf41d2c788be2 SHA512 c8ec998b3b7dc10d416406c0e421c1909e67c7bcd8479674520c0371615d131c75f59f1fb46f19c38cacdc1a42119534d66ace9ba58d0230a96f4f6baf0df185
EBUILD pytest-xdist-3.3.1-r1.ebuild 1053 BLAKE2B 70a5271cf02236de13d8452ea00397860af6c57bb1fb5cd5ebd119e7ecbf0593e14b72cc38f8401bbbc72ca89707ab20fb1f7bcc0b7ba1a3dd54115203cff3d6 SHA512 18816a29fd4e6885912e2cecdac3e9e8d13fef6a06681f5fa905b3f5b81c695d1195e3070540172347a6036ae175de744b00623023160f252bfa96a0e217e6b5
+EBUILD pytest-xdist-3.4.0.ebuild 1061 BLAKE2B 3cc707cfa3d284e4b0dbea9cd28220c6b60bdacbd79ac7d54f6f46c44f392e2d6819d306bc6515f5f78e230cec51dc8947516431abbaf4660e53844216b1d907 SHA512 7948f46c67b08e478b40a0abf482b89339bc3dd3e2cd647c3a823856e7e3febf2808e1ea8649929edbbfff94ea372672c88e6e47c7a63092abc92190c2295f34
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild
new file mode 100644
index 000000000000..441f239a2f03
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}