summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/pytest-xdist
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 1a549131c7cc..102c7245e875 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -5,5 +5,6 @@ DIST pytest-xdist-2.1.0.tar.gz 66332 BLAKE2B ac3c19a32bb9153537edfcf55bc65601166
DIST pytest-xdist-2.2.0.tar.gz 64781 BLAKE2B 17287c28f31c42c6a8fe3622d4ba920a530e0ced3bc99cffd8f9de91c3498cc2a3b654cc32bd5b09ee8ec6c1f64226aec736acafd73397be2eb34bd3d192bb46 SHA512 2027f8512fbd6cb68ab36eb774b9d8b7e855c181733b884f394d0e84994926b4fe6158dbd55808328b262497036f101e71cb86553340eba0031d654f34541689
EBUILD pytest-xdist-1.34.0-r1.ebuild 1036 BLAKE2B f576f44fdb55876e9cf7ccaec9ce5ffeede2095111a48f2455da590cc4c053ffac094b21baad142dc9ed54c654af423b29c4f7719dd32ff49da2d2f149e666d3 SHA512 3dc96e04f982a62f24f9ab9b2748dbd1a97c486ae3feee09b2e6fbd1ae4af6910455c456537453fa48d3cb85e03ac09acd7d26512a054e3aff83b5dc28591f62
EBUILD pytest-xdist-2.1.0.ebuild 1147 BLAKE2B 5f8b2db3dda86e53857ae6155e4c13ec868f744b9113c012ee961cd651584f010125d3ae3539deb5b3bab106397211cea17de81f8c506e9d1fc7e2cc50a4f7b7 SHA512 c9ac3c5c1d0e4d728e0edaa5ae122248a0c6d7ef426573e50274385b0ccca14feb3dc4a1112e00f11a23bf8529a036430b8f239cfde386d0c9cc407dd19ba5a4
+EBUILD pytest-xdist-2.2.0-r1.ebuild 927 BLAKE2B a77208de373f965e3719d00b21ff639b3a6af406286059802bd668a39aab99ff31e0fdbfba55c0daf7c3e611ae5b7fe31cb8fc0c8abfe03f0e1d3130f3d9ab9b SHA512 8c113df2b5c3f999eb19fbf8f0e03c5580dcea60a6e3125a1464c0f79a3d799452654a6075ecd2fec85249880977ac431dc050b6b20e637e70760eea70272e30
EBUILD pytest-xdist-2.2.0.ebuild 917 BLAKE2B c19d098863698507d64abf3724e0de9e411ed797f30e75d3d3e6be0c087830c1d54305b04d2e6e15175fecc25020a26957f7472203d33303619d1e4bfd39a4c2 SHA512 2af3e8f5fae4fc3a1a8b9ab51c7ac9f9fe1d7a4e05b9f6e03d1a9f067e840c1d18d551f13b192e041566d4b05a82318735be746eaff728bf0c2ca76b85d2e8b3
MISC metadata.xml 402 BLAKE2B 9e24660b4146f94ecdf375e3bd89a9ab01157ab7c7e9b37fa183eaad12edfbb6574ecef4a98e6079b3dd81e6614b5eb23b0bfd69c9468abde7bbc073e8ef44b4 SHA512 7fbab209b81bba0684b9dad109dc7ba64f9c496e5ad69fcbc659f9361aa131f6779a5419a54112b4ff1c2a63a9deef5f36791551165b1b4b7219c7a00fe93060
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..25660cca3a20
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest