summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
commit2ecd7994be1409f2a65bfca700904d2a78fd7bbe (patch)
tree0248ea4d4f411ea88c27470c15ebc725bb04baa1 /dev-python/pytest-xdist
parentc22e93ab35a8cb604c41623a7b2cda059c462b70 (diff)
gentoo auto-resync : 26:10:2022 - 03:54:55
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index a7b48e9a344c..2f4217714501 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,3 +1,5 @@
DIST pytest-xdist-2.5.0.tar.gz 72455 BLAKE2B 4d7427e8a7d85d7b0dcae2697fae0f51913a3a2414fabbb192a8e3938431f5f121677dd43adecfb1fc7f3dd6feb94901e28b0a96787a2c2eadc1504aac55068f SHA512 22da4db7cdd6173fb8377b6adc30b5617ccb0bb308cb5d30980484dd7ddff87cf2a485ae8522c7957d8954dd2f8a5542b9f63b0fa7184cc44e50dbafc3f4e909
+DIST pytest-xdist-3.0.2.tar.gz 69590 BLAKE2B b7e471e1888f78e1c91a867cd1d06f373c255018f63daab4af30fe47df816721954f484006b59bb38d58f9525712a5bc7bb6f00d190bee3580b82baf9b2cb55d SHA512 8b03dd156b7ef82b3b0c78f8aeb83410ce3014e3764aeca4161d57fe2ad557f0316ca86dbf06ac79ddc677df3dc838161fe427b0d1d9ba9446612360eb99fbf2
EBUILD pytest-xdist-2.5.0-r1.ebuild 1123 BLAKE2B 79d4a01654de1c96d9f12581b221e68b519e1e860858e9d836e2d636b6b93635f8b24f3ff8fb26034a55d6dfc799391a508e90dfeb2e420bbbc7f652de6f2ff7 SHA512 7a92a6e4eb4399a4837ca7453d8a4c9c56a9a05863c01bbce39e632b11d2e66ccec6f650a4c86df96a22b6a4bac52185f3bd93ce4e94261c2291cc9b10e001f5
+EBUILD pytest-xdist-3.0.2.ebuild 1131 BLAKE2B c7d846c8e378993ae77dd0f67264658ce09f748ae45eb0504afca76b0ef9bb4e91760ec4dd7c57ae4e55828b6e72941ac56ccd620a9528c115f4bc39bc7e81e8 SHA512 53dfa89a39676e42a3db1cdf785e45dba00cf8bd842f09a65fb67e8ed2f19e6bbb42061eaed90efe9ca49ff2e5da65a289e19f5fa427e4894b7c33cb147684c1
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild
new file mode 100644
index 000000000000..1079a190886e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}