summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
commit268f9f01921ccb921b794d43092c5f29c1e96c56 (patch)
tree07329b3a8cb5d315182a2ec2b2f4a4b36374724d /dev-python/pytest-xdist
parente3a48e635527f3e2d2254e9631f7a5758df9c3fb (diff)
gentoo auto-resync : 08:01:2023 - 06:15:27
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest2
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild45
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index fba74de53453..2159a14ade2f 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-xdist-3.0.2.tar.gz 69590 BLAKE2B b7e471e1888f78e1c91a867cd1d06f373c255018f63daab4af30fe47df816721954f484006b59bb38d58f9525712a5bc7bb6f00d190bee3580b82baf9b2cb55d SHA512 8b03dd156b7ef82b3b0c78f8aeb83410ce3014e3764aeca4161d57fe2ad557f0316ca86dbf06ac79ddc677df3dc838161fe427b0d1d9ba9446612360eb99fbf2
DIST pytest-xdist-3.1.0.tar.gz 71977 BLAKE2B c29622377743aec0a90f0e92af866a63106b9c37abee379222fd2b5c40f0607c33010bb5d2cb5212fc90a438d787ecb435f07c31e0db7a10599696c33b309a32 SHA512 884cdd85754b36338666cbdd71575ef18465730cfc4ab7333b93aa46823c1dc33e8055117241f4c87e1b8c82492881cc0f91ef1bb2ddc164aa00bfa1e5e2d245
-EBUILD pytest-xdist-3.0.2.ebuild 1123 BLAKE2B 79d4a01654de1c96d9f12581b221e68b519e1e860858e9d836e2d636b6b93635f8b24f3ff8fb26034a55d6dfc799391a508e90dfeb2e420bbbc7f652de6f2ff7 SHA512 7a92a6e4eb4399a4837ca7453d8a4c9c56a9a05863c01bbce39e632b11d2e66ccec6f650a4c86df96a22b6a4bac52185f3bd93ce4e94261c2291cc9b10e001f5
EBUILD pytest-xdist-3.1.0.ebuild 1123 BLAKE2B 03571179e339fbbceb8fa84f9c9a91f9aaaa9df9182d536c7ca1cacaf67e41bd342b102567ecddbe4008e906d470862e73126dc3bc6ac86ee212a832036054ed SHA512 50d7d3295ae7e94996c2f323f6c4cc0bb8f2fe030cd182170e9a679ed316fe79700d75647619bfcecd79953ee811f27397cd67d6b6756369a57e6f9bb7a2acff
MISC metadata.xml 403 BLAKE2B 0aef0787ad01d8e5e5a0588b95740ca54527c1f425d17cc6655308ca478597ebdbfc35165e88864163929104aba9820848b63c17c3d77b238c4f0e17d9b98261 SHA512 c12b3e2a13b6497f748b373753410df996955ddcb9631b310104f2ae31a1427d983462c242692c1b6f9a9b9cd36b7f4aaef58e408543572c040e3dbeb38848fe
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild
deleted file mode 100644
index b43a7eda10d9..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-3.0.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="
- https://pypi.org/project/pytest-xdist/
- https://github.com/pytest-dev/pytest-xdist/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- epytest
-}