summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
deleted file mode 100644
index 883e7c88dcea..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# pytest-xdist >= 2 fails with pytest < 6
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
-)
-
-distutils_enable_tests --install pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- distutils_install_for_testing
- epytest
-}