summaryrefslogtreecommitdiff
path: root/dev-python/pytest-twisted
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/pytest-twisted
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest4
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild62
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild2
3 files changed, 2 insertions, 66 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index e377ae0018f5..087dafb4f411 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-twisted-1.14.1.gh.tar.gz 17114 BLAKE2B 36b851b734acc03919dc03842d942d205468375d9318d4ce4f880532fca29d31354125fd2ab8149a50bcf29e46ec812898b7167e34c0fa1276dcd5c2aa36ccd1 SHA512 d5b6d629ed3cf7ae1537e76494fa7eb4bbb9767cbc50d97a5657c668b381f39236acc6224b3754d62e2cccd4dff7e6161265ddc6a939f0488cef53eeade0eae9
DIST pytest-twisted-1.14.2.gh.tar.gz 17120 BLAKE2B d12c00c5a01c8219626f5a85d5cee4b2f0fc27d4dbea5c38e4fa7e374d1ca04098b1e8bc453ff1391415b2999eb1bb1f0472cef85bb4b4b2e50a1d2632cb6177 SHA512 51c915dfba829442b68c981f80d42cc22ece12a81388f239211ca73bb76dbfadeec76722df44b2e6b6473a4a3886031846a47b855ef217ed240a7c28d20f6160
-EBUILD pytest-twisted-1.14.1.ebuild 1472 BLAKE2B e22906e3e33582187978a04289e63a0036a4bf92a6250b0c1037b3be554692acfe891588d4add8b14a17c229653d5146a4cd3fef4850e709b7c65287337df60e SHA512 eb416f4d78ec5b3ce398c54c4192c2b52dcd6b05bf908f709f953d4a42f9261baf8ff16727339d5727d715eb02c1975619e20f5ff86757803f119f94d6769167
-EBUILD pytest-twisted-1.14.2.ebuild 1296 BLAKE2B 47a87447bd0f96e737a5206707a2a941f0cabf947f0546deb2c01128fcb643c02305017e0fdb8e9a405dc2c60ad1e7ffc0436ae120da5de65c51816cc4baef83 SHA512 5b82ed541fbf63dfe7626ef753e9e21e9454d9bc71ae89894d14b515946dd601e12f374354d1e47c6f451d345d07b8073fcab5fa65489bddbede92b260b83dc6
+EBUILD pytest-twisted-1.14.2.ebuild 1294 BLAKE2B baf4e7832f9f9a0ae1cc7ae9f2e0e7bb69f37abcae19f19399e7d7f80669bbdeef1d46c482c426eaca665465fc3081811b69b35d23468aa3e1dbbf44b0db6640 SHA512 429b347e3fbe57063097e1c7d63d0917092115e2201b8a590c09d3934fef4cd4f238c9bd2eb79109608f43080c7d0264fa4b1223f93ad3f05d234ccd0fe71c6d
MISC metadata.xml 510 BLAKE2B b0a57f26f53646876843a2d19d2eae54f4ba393afddc58dff646e5aa0a755c0920223d572fd4fcf5d6540c1512e52f798045424d09713aae15e4d4310cc3d10b SHA512 0faeb8637414016721807155ce0546912cc6b9507ad21936491397efa55108e60c5973753941b11d61070f35540113470e533f4e233a1925183d3ae77d2d4949
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
deleted file mode 100644
index f90693d8ef2f..000000000000
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="A pytest plugin for testing Twisted framework consumers"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-twisted/
- https://pypi.org/project/pytest-twisted/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-twisted/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # If we let pytest-twisted autoload everywhere, it breaks tests in
- # packages that don't expect it. Apply a similar hack as for bug
- # #661218.
- sed -e 's/"pytest11": \[[^]]*\]//' -i setup.py || die
-
- # https://github.com/pytest-dev/pytest/issues/9280
- sed -e '/^pytest_plugins =/d' -i testing/conftest.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_twisted
-
- local EPYTEST_DESELECT=(
- # regression with pytest-8.2
- # https://github.com/pytest-dev/pytest-twisted/issues/176
- testing/test_basic.py::test_async_fixture_module_scope
- )
-
- epytest -p pytester
-}
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild
index c6585205c277..ea6188cc0b20 100644
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]