summaryrefslogtreecommitdiff
path: root/dev-python/pytest-twisted
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 19:01:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 19:01:00 +0000
commit60945053af0588a6219a4a6867aace9e7b47faeb (patch)
tree01b47053786c26a3e31ca562d46dfd252fe22cd7 /dev-python/pytest-twisted
parent26f79803004cb53e92cf2f0e889de89979385aa9 (diff)
gentoo auto-resync : 19:11:2022 - 19:01:00
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest4
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.13.4-r1.ebuild44
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.0.ebuild2
3 files changed, 2 insertions, 48 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index d9af42c28ae9..d12c80cdb950 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-twisted-1.13.4.gh.tar.gz 15687 BLAKE2B 8e1024da02a5a1c9c33df96c18a355b9be5757446d9f5495ba1f043c15a2e44efd6e59693986a0684d77b8518393ce9f382d62e3d1e5b903876e8cff34efb427 SHA512 99899ad73f87582023a0e639986a287b4571638be4f1ae134078a15a4d4bebd24153f813c993382603edc14306c12931e2daf517d7998e48d3d19b8469c0b7aa
DIST pytest-twisted-1.14.0.gh.tar.gz 16234 BLAKE2B 1f0470893135127111194dcb726e5c16c8ce6911456eae7068035a001010b2513f5b1d7507c84f8ebf183042144c3cec3fb4fd1f060d987f5e1f3c053f29ed0e SHA512 d3c1b7320f87bd32bec992b807baf235c13e5595c93895eb7df91f709d7ab92dbbc30a47f4341477d7ba9541958efa1d4ef7d355023050747b401bb541314bc9
-EBUILD pytest-twisted-1.13.4-r1.ebuild 1180 BLAKE2B 7c07bb50844469c75a9dd56f1c7d74d0c6058b4a04e46bbf811cd6a98a1750b8ddd416240e61108965650a66a7a4734e70de3602f8a12cd23fcca77d40204edb SHA512 5f19e960b339342c17786fd0583f2814e5dbc47a50f3c81953fe349832680f9aab5268f711eac2644ccf875af7c941016b7d8d5e3ac5fb0205391e606c8fffd7
-EBUILD pytest-twisted-1.14.0.ebuild 1234 BLAKE2B a6ed482885a45f9fe5ed34be7e4b3211ac30ee29e8c3a650eb5ed27a95bbb7ab86235bcf23255895d368f956199de3d5bf74ede2e5630f7acd49febcc4af0018 SHA512 f85a53c6a63a2a2776447e3642fca14c1f441e106850d58436e292717002a54ba2a8a62eb27c6f5adc59eb25a720b8e6182effbd226e5eacd2946fe31f1a573e
+EBUILD pytest-twisted-1.14.0.ebuild 1232 BLAKE2B c6bc23cf76547cf0932e916f4a275117a649ef2c745fb8db2be006c39b8303b7d1efab94b5d78fc76fce12377fa12e567bae84e72936f517ccc233604682ee80 SHA512 ab2e17374cb54350896d0570493ac09b07d145d7583929fd58dbe3ef50aaed841ab678d47c3aa8fba5253b669ef514f4e69f1080dbc6f76fe6a7219c84fdb6ae
MISC metadata.xml 642 BLAKE2B c081296008b9003b05ba94fa6942b41818d3b68a8ca143437fc134b44c39d392f5cb05f2c65ed8a7b7d4f0115ae68c986bc6bf60d9a7d624919e20a9d2cc06d6 SHA512 4abfad276da1a0915bab78a189519900b71d5e87a71ca93332381d08af734128fe8cc1a325945ab33b3098a51a7d62ba53525615a6345419b5f94bb4c8f59438
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.13.4-r1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.13.4-r1.ebuild
deleted file mode 100644
index 9dc7a2ba31ab..000000000000
--- a/dev-python/pytest-twisted/pytest-twisted-1.13.4-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="A pytest plugin for testing Twisted framework consumers"
-HOMEPAGE="https://github.com/pytest-dev/pytest-twisted"
-SRC_URI="https://github.com/pytest-dev/pytest-twisted/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # If we let pytest-twisted autoload everywhere, it breaks tests in
- # packages that don't expect it. Apply a similar hack as for bug
- # #661218.
- sed -e 's/"pytest11": \[[^]]*\]//' -i setup.py || die
-
- # https://github.com/pytest-dev/pytest/issues/9280
- sed -e '/^pytest_plugins =/d' -i testing/conftest.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_twisted
-
- epytest -p pytester
-}
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.0.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.0.ebuild
index cb6ee5309a59..41a15b58b678 100644
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.0.ebuild
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.0.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~riscv x86"
RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]