summaryrefslogtreecommitdiff
path: root/dev-python/pytest-twisted
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
commit04ac238703da84168e02b06fb131d1d17d85be23 (patch)
treef32aa3a6b6a6c879a798006535ad544bf888df73 /dev-python/pytest-twisted
parent6405cba4bf18141460bc9fcb8f5580532d4b46f8 (diff)
gentoo auto-resync : 29:09:2024 - 01:25:46
Diffstat (limited to 'dev-python/pytest-twisted')
-rw-r--r--dev-python/pytest-twisted/Manifest4
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild56
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.3.ebuild2
3 files changed, 2 insertions, 60 deletions
diff --git a/dev-python/pytest-twisted/Manifest b/dev-python/pytest-twisted/Manifest
index e0abfb62cd8e..16fa18507fc4 100644
--- a/dev-python/pytest-twisted/Manifest
+++ b/dev-python/pytest-twisted/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-twisted-1.14.2.gh.tar.gz 17120 BLAKE2B d12c00c5a01c8219626f5a85d5cee4b2f0fc27d4dbea5c38e4fa7e374d1ca04098b1e8bc453ff1391415b2999eb1bb1f0472cef85bb4b4b2e50a1d2632cb6177 SHA512 51c915dfba829442b68c981f80d42cc22ece12a81388f239211ca73bb76dbfadeec76722df44b2e6b6473a4a3886031846a47b855ef217ed240a7c28d20f6160
DIST pytest-twisted-1.14.3.gh.tar.gz 17412 BLAKE2B 00516995770e338ffcbd611d31e96576489cc188aba778913938c0fee511e24df887dc1ba41f5ac63cd85e9efec41a78242dd90705a9769bf7c37130749646c2 SHA512 fce003bdf7684a3a3f3bc45d0d7adfbb6350ee7b2f69a35c2ddbd66073e2a993a127fef24008d8300493334543baaf902033316e2c923c6b827a26d0a7356bb6
-EBUILD pytest-twisted-1.14.2.ebuild 1294 BLAKE2B baf4e7832f9f9a0ae1cc7ae9f2e0e7bb69f37abcae19f19399e7d7f80669bbdeef1d46c482c426eaca665465fc3081811b69b35d23468aa3e1dbbf44b0db6640 SHA512 429b347e3fbe57063097e1c7d63d0917092115e2201b8a590c09d3934fef4cd4f238c9bd2eb79109608f43080c7d0264fa4b1223f93ad3f05d234ccd0fe71c6d
-EBUILD pytest-twisted-1.14.3.ebuild 1296 BLAKE2B 47a87447bd0f96e737a5206707a2a941f0cabf947f0546deb2c01128fcb643c02305017e0fdb8e9a405dc2c60ad1e7ffc0436ae120da5de65c51816cc4baef83 SHA512 5b82ed541fbf63dfe7626ef753e9e21e9454d9bc71ae89894d14b515946dd601e12f374354d1e47c6f451d345d07b8073fcab5fa65489bddbede92b260b83dc6
+EBUILD pytest-twisted-1.14.3.ebuild 1294 BLAKE2B baf4e7832f9f9a0ae1cc7ae9f2e0e7bb69f37abcae19f19399e7d7f80669bbdeef1d46c482c426eaca665465fc3081811b69b35d23468aa3e1dbbf44b0db6640 SHA512 429b347e3fbe57063097e1c7d63d0917092115e2201b8a590c09d3934fef4cd4f238c9bd2eb79109608f43080c7d0264fa4b1223f93ad3f05d234ccd0fe71c6d
MISC metadata.xml 510 BLAKE2B b0a57f26f53646876843a2d19d2eae54f4ba393afddc58dff646e5aa0a755c0920223d572fd4fcf5d6540c1512e52f798045424d09713aae15e4d4310cc3d10b SHA512 0faeb8637414016721807155ce0546912cc6b9507ad21936491397efa55108e60c5973753941b11d61070f35540113470e533f4e233a1925183d3ae77d2d4949
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild
deleted file mode 100644
index ea6188cc0b20..000000000000
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="A pytest plugin for testing Twisted framework consumers"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-twisted/
- https://pypi.org/project/pytest-twisted/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-twisted/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # If we let pytest-twisted autoload everywhere, it breaks tests in
- # packages that don't expect it. Apply a similar hack as for bug
- # #661218.
- sed -e 's/"pytest11": \[[^]]*\]//' -i setup.py || die
-
- # https://github.com/pytest-dev/pytest/issues/9280
- sed -e '/^pytest_plugins =/d' -i testing/conftest.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_twisted
-
- epytest -p pytester
-}
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.3.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.3.ebuild
index c6585205c277..ea6188cc0b20 100644
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.3.ebuild
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.3.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]