summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/pytest-trio
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest3
-rw-r--r--dev-python/pytest-trio/metadata.xml13
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
new file mode 100644
index 000000000000..0b0a172ebfa3
--- /dev/null
+++ b/dev-python/pytest-trio/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
+EBUILD pytest-trio-0.7.0.ebuild 1072 BLAKE2B 3fb2f11af8ba24b57cf3ce03b5829df8b27d5eb5ae83c15b140ac418519fba125bf4eff58ea8731cc14be9b6cb237f3deafc0deeffa16134bf2b94e457b41bd2 SHA512 40fc06af79f7937cda2482c69e1ed4a63bb4dbf936f7dabd8b8c48afde991d9503f03e32859f5a2519d7e00c2e79dce58e152ada0ef5890936e9cc664499ba2f
+MISC metadata.xml 419 BLAKE2B e4bf5b235b2b851e2677e138ab488308deb5265d00afa1c5ff2760e817c7a8c9fdbaeb095bf63ad6c9ff0a5dbb60df5c047b6ab9564c590becb7da76a3258db0 SHA512 1d21a7481afb771ee6507f6475f9460bd0f8441de68987e2a31923091b33bba4a9fe5d6a8ec0b313d8277942656388c1ae6fb9b7cc0de601655762b66b111e0a
diff --git a/dev-python/pytest-trio/metadata.xml b/dev-python/pytest-trio/metadata.xml
new file mode 100644
index 000000000000..e724d1bb8497
--- /dev/null
+++ b/dev-python/pytest-trio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">python-trio/pytest-trio</remote-id>
+ <remote-id type="pypi">pytest-trio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
new file mode 100644
index 000000000000..5f6946b22be2
--- /dev/null
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
+HOMEPAGE="
+ https://github.com/python-trio/pytest-trio
+ https://pypi.org/project/pytest-trio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs/source \
+ dev-python/attrs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-trio
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv pytest_trio/_tests/conftest.py conftest.py || die
+ distutils-r1_python_prepare_all
+}