summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
commit1ab8c7f6ed10f981d767a0acc2f420cf86775f12 (patch)
tree44eb556f62eeb50b980ae79712fa5087c2c7e3b0 /dev-python/pytest-trio
parent29badda007a3bcd85bb351f602790eb3b8922448 (diff)
gentoo auto-resync : 02:11:2022 - 09:09:18
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest2
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.8.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index 6427a99e8120..cd09f01076ee 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
+DIST pytest-trio-0.8.0.tar.gz 46525 BLAKE2B 54660dc9b021af0ec18eace72f053223d16e89635c74d71329a005e5fee3bf6e2055cc29412d9de7443b2594ee53d68890d1e30ed7c94560c355d4342bb3d035 SHA512 79141021633b7b2d8a840d7eaf6a3447bccd59d1bd4909e7feba88a9ae8244376f281b64fde4333b5a575957e3f73028e389a9abf0d19a35417f15c47eeccd05
EBUILD pytest-trio-0.7.0-r1.ebuild 1410 BLAKE2B 97dae59eae0a296ceb1f966428e6fc1327ea94c7c31885d6bb170285e8fb9e97cdca433dd73e89606473006a6f828478f5ddb75eefcc062fe7325ea75fc2730b SHA512 5fec150eafe5735a4f795f4b4b5b6ab6ca8354bd3401bc10fbe11bd5500f7c06e1f6fce6d463a803ae908b5ca821beea16a43be7805b402526315ed1b22cf358
+EBUILD pytest-trio-0.8.0.ebuild 1376 BLAKE2B 1d9b69fc2ffb000d2929cff9f2c013f7e3dfe3feacd8040e88a60205d59d9ec2cd2307bf84bdb5ff15faec07f9992bb9a0e1e25c1556239d7ca643a5f512bed6 SHA512 f20984a007eb89e73c7fd74cfd45613be61706c4b7cdf45712e54f4c57a117765bdba4b4e6b4ff4f2f3d69cfa273796694b4072b5ed385c9039abd5f48650574
MISC metadata.xml 420 BLAKE2B 42bae65fb9b23797c96bdc057faebc577f89f0c83f27031079176c2a122cb15e70eb5937a8cd52d09b3d7c5a7d16f62768452c87523fdb0fad876b63836c171d SHA512 5dd3d9e96df753347ccdf41428b5faa1df217985d7cfda1d7bd933fdf755f8f254fd9fa80e7cbeedff318327c4ff4257d8598a17def8ee6144d27aa89305cc3d
diff --git a/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
new file mode 100644
index 000000000000..b45ef14decb2
--- /dev/null
+++ b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
+HOMEPAGE="
+ https://github.com/python-trio/pytest-trio
+ https://pypi.org/project/pytest-trio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/outcome-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.2.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/attrs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-trio
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv pytest_trio/_tests/conftest.py conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}