summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 15:20:44 +0000
commit177349fb1459039cc30cb8e3936af4117d038c16 (patch)
tree34c1bc161daefb8e152212dfba02b98da8a777a5 /dev-python/pytest-trio
parentc15acf374d4b25ba5afcb52435da6090f2d98a20 (diff)
gentoo auto-resync : 10:12:2022 - 15:20:44
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest4
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild52
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.8.0.ebuild2
3 files changed, 2 insertions, 56 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index dae4adf4c490..d845ef6e1230 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
DIST pytest-trio-0.8.0.tar.gz 46525 BLAKE2B 54660dc9b021af0ec18eace72f053223d16e89635c74d71329a005e5fee3bf6e2055cc29412d9de7443b2594ee53d68890d1e30ed7c94560c355d4342bb3d035 SHA512 79141021633b7b2d8a840d7eaf6a3447bccd59d1bd4909e7feba88a9ae8244376f281b64fde4333b5a575957e3f73028e389a9abf0d19a35417f15c47eeccd05
-EBUILD pytest-trio-0.7.0-r1.ebuild 1392 BLAKE2B 3ed1d0338eb55496fcb28e9b1bc8aa85cfa2d58b74b589c5eab707a6703c1ee2c9f7527bb01748537051b816b4d12f85cfd1761f50278ca19dd7c7e0b4f7e900 SHA512 b9343cb3c6f45acfd8486a89669e2a944fc5cd50ae18b36114da6cbd845fba0a77119b13ace30819e2a347f580206fde7918fbe9db3653a171f66624afae87ab
-EBUILD pytest-trio-0.8.0.ebuild 1357 BLAKE2B 90425cc7b57edf8fcbda1698fcdb7b55741353751f68e8bbb8362e999c9bfbb05468a74e79474bf26e4450453f5a9591b98ce110e96f6ae8c543643703d44756 SHA512 ea8f35b79976aca329fd7b8cca723377be46f801ea7e67f66816839cae42ba95e4fb4bcd8ec7b480b32307b3ff65ed0c6fe978ef36efe9f1a33cba813c83971b
+EBUILD pytest-trio-0.8.0.ebuild 1350 BLAKE2B 071fc4c2999162b01dba6028265d2e6d65cd04aa4e4e266d6658ec1231cac6107302364345520780a8724fbc383ccc28a05b2f94b49f27631fadf1339d9de83c SHA512 2154405356f2cdb21aaa412d26cfee45e05e44bd870500f329b26c4087576f06b854e93deca735a7a0b03ce1eaa1ce135c63aa02518981a0b77024ee2185da53
MISC metadata.xml 420 BLAKE2B 42bae65fb9b23797c96bdc057faebc577f89f0c83f27031079176c2a122cb15e70eb5937a8cd52d09b3d7c5a7d16f62768452c87523fdb0fad876b63836c171d SHA512 5dd3d9e96df753347ccdf41428b5faa1df217985d7cfda1d7bd933fdf755f8f254fd9fa80e7cbeedff318327c4ff4257d8598a17def8ee6144d27aa89305cc3d
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
deleted file mode 100644
index af426052c90a..000000000000
--- a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
-HOMEPAGE="
- https://github.com/python-trio/pytest-trio
- https://pypi.org/project/pytest-trio/
-"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/trio-0.15[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/attrs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinxcontrib-trio
-
-python_prepare_all() {
- # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
- mv pytest_trio/_tests/conftest.py conftest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # disable autoloading pytest-asyncio in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading pytest-trio
- local -x PYTEST_PLUGINS=pytest_trio.plugin
- epytest
-}
diff --git a/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
index bcd93cd9dedf..2fa2ee710418 100644
--- a/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.8.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/outcome-1.1.0[${PYTHON_USEDEP}]