summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/pytest-trio
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest3
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild52
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild4
3 files changed, 56 insertions, 3 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index 8582853c6bc8..81b870c007c6 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1,3 +1,4 @@
DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
-EBUILD pytest-trio-0.7.0.ebuild 1346 BLAKE2B 3b96d976861bb4a7c3a1d675c6dd4fd544ffe2c22b985b6842ad88d73db0a86d45f6aa2e5ec34f7bd1ebdda373682d250aafc5cd07c87c562270150b359161c1 SHA512 9c26a73a3d0a182c9721a60210c5ad025a85b26604e67edf43ef8fe8ca018dc5739e5162f055acd2aad042d87a95462368443b8d655a76ebb2646c38750b4e27
+EBUILD pytest-trio-0.7.0-r1.ebuild 1392 BLAKE2B 67123d00e836d92b6dc3483a97df70ebc2393d45cc8cc08d477235b330b15fa9f75193b952818dcd3dd66f9c7177f9833530d7154d6167a875456e964f733a37 SHA512 1aec3e9737269a8f62fe35b1dac6f52b3b54fd1340e0cfbeae2230a41d3bcd0625ce507cc8b1c841a3b3a0347b71566d69f7cb38bf6b93c19f8c76a0ce8c45ae
+EBUILD pytest-trio-0.7.0.ebuild 1352 BLAKE2B d8b2cf8f9c25872ed7e0109e60d477bfee74a0b97d6f9b0888de997c33b33ca3ee1b5fec5b3b7d939207245b3d99f7a0674a9315c6b4b5a27e57a8e4dca5e048 SHA512 8c239976d389d4f2c190da5a7cbcf751e9225fdfbfcc09cda700e1ffcded5fa4c70165850afabab096dcc2b9a8c91ddbbc4778163445d9e766243d8272be51c3
MISC metadata.xml 420 BLAKE2B 42bae65fb9b23797c96bdc057faebc577f89f0c83f27031079176c2a122cb15e70eb5937a8cd52d09b3d7c5a7d16f62768452c87523fdb0fad876b63836c171d SHA512 5dd3d9e96df753347ccdf41428b5faa1df217985d7cfda1d7bd933fdf755f8f254fd9fa80e7cbeedff318327c4ff4257d8598a17def8ee6144d27aa89305cc3d
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..ac9b1f5bd507
--- /dev/null
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
+HOMEPAGE="
+ https://github.com/python-trio/pytest-trio
+ https://pypi.org/project/pytest-trio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/attrs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-trio
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv pytest_trio/_tests/conftest.py conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
index 612dde1c4124..d5f1cdacce4a 100644
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1