summaryrefslogtreecommitdiff
path: root/dev-python/pytest-tornasync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/pytest-tornasync
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/pytest-tornasync')
-rw-r--r--dev-python/pytest-tornasync/Manifest3
-rw-r--r--dev-python/pytest-tornasync/metadata.xml13
-rw-r--r--dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild35
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-tornasync/Manifest b/dev-python/pytest-tornasync/Manifest
new file mode 100644
index 000000000000..4c76a776d8ac
--- /dev/null
+++ b/dev-python/pytest-tornasync/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-tornasync-0.6.0.post2.tar.gz 6201 BLAKE2B 6b6a2f941e649fb33373ef39b9d848d68a8af0f5e0d1a5e4496a9160e8e63ea108832437e87382c8203bb2c75673fad37b4ebd76157913199eb1661cd0216591 SHA512 2e258913b17a5442d18928833ee7e9771b6dbd148dbf251a7661432a54d4b9f9f3a7c396134eb544c0e3ce0af48c99d2d632399ac6ebdcf148187a7a523f4974
+EBUILD pytest-tornasync-0.6.0_p2.ebuild 787 BLAKE2B 7c627cd66f6e2d82b11312081d7fb0709fb82be7035cd21018fd60a90166df14f442192fcfac86875960870e2e476720d7030c48cb8b429ba7674e8e3dff9934 SHA512 6f9230dccd6add87a83f4a76b63091f3b750c627a7347a2f9b748fa5d4ac7d4bf552f91d84e38320f2495d739feed6d6b0810169dd2b5d7c91bf260f3247e462
+MISC metadata.xml 422 BLAKE2B 60b4b2d131e88e8132e6d8be715fc0b4cb323193a5de68d53c667040ae1bb40308a361b49dbdc35c99df8ad1917ef01731fd6b92fd106bedfa35616472bd4ed3 SHA512 9b412c3ce930d5f009e9b719cf9674db5409279f3e6c9f206d07a76157ab95d674929e4aef198fba6464184c8b8b83ee3672efd2c021042f0e88314a0a2cf59d
diff --git a/dev-python/pytest-tornasync/metadata.xml b/dev-python/pytest-tornasync/metadata.xml
new file mode 100644
index 000000000000..2b85afa59328
--- /dev/null
+++ b/dev-python/pytest-tornasync/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-tornasync</remote-id>
+ <remote-id type="github">eukaryote/pytest-tornasync</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
new file mode 100644
index 000000000000..7beeaea50ebf
--- /dev/null
+++ b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing Python 3.5+ Tornado code"
+HOMEPAGE="https://github.com/eukaryote/pytest-tornasync"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P//_p/.post}.tar.gz"
+S="${WORKDIR}/${P//_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: fix this
+# E ImportError: cannot import name 'MESSAGE' from 'test'
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the license file
+ sed -i -e '/LICENSE/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}