summaryrefslogtreecommitdiff
path: root/dev-python/pytest-tornasync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/pytest-tornasync
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/pytest-tornasync')
-rw-r--r--dev-python/pytest-tornasync/Manifest4
-rw-r--r--dev-python/pytest-tornasync/metadata.xml4
-rw-r--r--dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pytest-tornasync/Manifest b/dev-python/pytest-tornasync/Manifest
index 7b37fe9b44e9..a66c77977ec9 100644
--- a/dev-python/pytest-tornasync/Manifest
+++ b/dev-python/pytest-tornasync/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-tornasync-0.6.0.post2.gh.tar.gz 6157 BLAKE2B 315526ebfe1801ccb10258c0258a83f16efdc28b2b2dcdeece94423a0230506fc08ef176655e35c7aed007fad40501d6a1b0ad20728dfc58faddaad003fb1182 SHA512 fe21bc724b0bcc192f0ca7628302cda0b8122e1b5aedd4f7a0818bc757f45c1d4f76b2aecc35396349df7fc5b43c1278a5a06af44c2b29d8bf1e691164324231
DIST pytest-tornasync-0.6.0.post2.tar.gz 6201 BLAKE2B 6b6a2f941e649fb33373ef39b9d848d68a8af0f5e0d1a5e4496a9160e8e63ea108832437e87382c8203bb2c75673fad37b4ebd76157913199eb1661cd0216591 SHA512 2e258913b17a5442d18928833ee7e9771b6dbd148dbf251a7661432a54d4b9f9f3a7c396134eb544c0e3ce0af48c99d2d632399ac6ebdcf148187a7a523f4974
+EBUILD pytest-tornasync-0.6.0_p2-r1.ebuild 1031 BLAKE2B 90b4806cc53fec405d851f0211480bb82b7389a5191d261098176613620838a753b5a37a07862553bceb2227bef30967ee79ef4644aad83c442cd842ab784da8 SHA512 25d4acc9b8de30fa2515f5e9f38f11ffc52def5eac2c1bbaca53b51f04ff1dae1814765f3160c9294be0f1f37b4a5bfc0ef478f242313ecb7bf4888b53d7cde5
EBUILD pytest-tornasync-0.6.0_p2.ebuild 779 BLAKE2B 078ac52fd3923e49313d2e0e41bac3ab77b9dccb54c9793011580aa9d605fd73da67d71b11fdb271638c8b00499f010cc4f27e40f54e3431b015a6e63fb37acb SHA512 4fc4dfd194f5f5623d6b7e428e1923fd0a9a92264d350dcad43eea26d9575d06569b8bc1c519a555cae71a36db1b1c50b7e1e84820a2a298258906794d212ab6
-MISC metadata.xml 423 BLAKE2B 5f62fb4f40fb223be599f7ad934bc2c23d2fd843cd90708eed0042e464c89c1385375d7217707646ea4b5d98903f7fbace04c465eebcfef102805346b2fe9cbd SHA512 22ad021af9cce23bfe4eb799cf015beb26fd042daddf0f8b6e6adb03365b850f2a3a3aa623c5f3c5b9b56a8149d6d53cb254b0f9730e0cbf55ef2d0400981d08
+MISC metadata.xml 524 BLAKE2B 8a0c19e391bbfedd1c3c1b7761d41a706a75954890f304e47b68a0109eafa83925de99201d239426c224d8fa7cc8a309249fb5d7addcf8b1a7148d4ba0fcf45c SHA512 85dae8cda61ef39f75029dddf980fe6517454319661d337ac3f70aedb62528194d239a98933a63c42c63cf1b7ccc7997d206726d07217a6ed703db3df4889f78
diff --git a/dev-python/pytest-tornasync/metadata.xml b/dev-python/pytest-tornasync/metadata.xml
index 531d235187da..abd0597a1324 100644
--- a/dev-python/pytest-tornasync/metadata.xml
+++ b/dev-python/pytest-tornasync/metadata.xml
@@ -5,6 +5,10 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">pytest-tornasync</remote-id>
diff --git a/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild
new file mode 100644
index 000000000000..597b80841a4d
--- /dev/null
+++ b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+MY_P=${PN}-${PV/_p/.post}
+DESCRIPTION="Pytest plugin for testing Python 3.5+ Tornado code"
+HOMEPAGE="
+ https://github.com/eukaryote/pytest-tornasync/
+ https://pypi.org/project/pytest-tornasync/
+"
+SRC_URI="
+ https://github.com/eukaryote/pytest-tornasync/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the license file
+ sed -i -e '/LICENSE/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}