summaryrefslogtreecommitdiff
path: root/dev-python/pytest-tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/pytest-tornado
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/pytest-tornado')
-rw-r--r--dev-python/pytest-tornado/Manifest2
-rw-r--r--dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-tornado/Manifest b/dev-python/pytest-tornado/Manifest
index 5c3621a5959d..bda2cb5d5b7e 100644
--- a/dev-python/pytest-tornado/Manifest
+++ b/dev-python/pytest-tornado/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-tornado-0.8.1.gh.tar.gz 12616 BLAKE2B 0e9668056c5f6dafd242f311825f830fe1e6428f4c38d030bb0a119f8ae54d511debdb4f839adcfa0881d6ecc79e4889dbed80121cd7a3d4bfb75dd901cb234e SHA512 e655ee9e28461c68b6cc642dbbb203a31154305a603951641e795c605f55970243bb9f7a8858a44bf70faba3d647bea6cf1525f2f9655a968cabbea43beec3d6
DIST pytest-tornado-0.8.1.tar.gz 12616 BLAKE2B 0e9668056c5f6dafd242f311825f830fe1e6428f4c38d030bb0a119f8ae54d511debdb4f839adcfa0881d6ecc79e4889dbed80121cd7a3d4bfb75dd901cb234e SHA512 e655ee9e28461c68b6cc642dbbb203a31154305a603951641e795c605f55970243bb9f7a8858a44bf70faba3d647bea6cf1525f2f9655a968cabbea43beec3d6
+EBUILD pytest-tornado-0.8.1-r1.ebuild 747 BLAKE2B eaf64b618d7ff84ca47f42cb786dd146b4fc8ae06272d2481abc9e22a35db4601ec28c6381f46a5e036007f857966e3535159adb4658a190e984dbe7ae9c286a SHA512 55afeb1ac5267e3641610efb506d5e80659f14bbf5eaeaed430089a04835685e299cc3f99918504a6914540faf4a0bd2baca30bcf8ee0001845e79baa942923d
EBUILD pytest-tornado-0.8.1.ebuild 695 BLAKE2B cf7b0a49c77897f3c643c77e4f0e4e84e4826f65d017889f8e2b043b9d70bad481042e2af909788384aad134c079ffb14ef4fc471fef75da271e4345b78fe717 SHA512 8701a3968d1afa9aa6d42ec22755a95ef768bfa134b6ad2054330a8f9d2635a2554b5e44a7600a16bd5b6d533cc9b99070d987552cd71e71cf2222942ccdd137
MISC metadata.xml 518 BLAKE2B 837787bd26b38f956e70d08e16813f69600a6d0a56755574e2a6f6be273ad5301a4680116cb6a0296891b508fb35f3cd090b090fd1df84ec4264f27425055c61 SHA512 923bc0cbc46725a21ae271c09b4bf9a17a4f80c3ed9b99d2d24c00343091b7ef7ad75988387be994bf43131b8e810a56fc45390a061ed647711cd57de7447820
diff --git a/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild b/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..9855ec68a82a
--- /dev/null
+++ b/dev-python/pytest-tornado/pytest-tornado-0.8.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures and markers to simplify testing of asynchronous tornado applications"
+HOMEPAGE="
+ https://github.com/eugeniy/pytest-tornado/
+ https://pypi.org/project/pytest-tornado/
+"
+SRC_URI="
+ https://github.com/eugeniy/pytest-tornado/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest