summaryrefslogtreecommitdiff
path: root/dev-python/pytest-toolbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/pytest-toolbox
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/pytest-toolbox')
-rw-r--r--dev-python/pytest-toolbox/Manifest3
-rw-r--r--dev-python/pytest-toolbox/metadata.xml12
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-toolbox/Manifest b/dev-python/pytest-toolbox/Manifest
new file mode 100644
index 000000000000..6934d94c77c8
--- /dev/null
+++ b/dev-python/pytest-toolbox/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-toolbox-0.4.gh.tar.gz 8594 BLAKE2B fb1f19513e9e4b191c3eb995cc5e9445bc9f19affef87350d925c5465210c4de945b91120f86664c1dcf02a638595a7725cf88e3244e377ae77558c70d65643a SHA512 ed27700ff77cd607be808142cc310cd2b7461e55b3f8352d304ef8ca6c5e6c060c67a63238a1025407868ab8e229c4a16eaaa56aa75000159762001accb67752
+EBUILD pytest-toolbox-0.4.ebuild 644 BLAKE2B bab42f604b99b980948880f47618e8fa2d357ca19b316cb861eaf16404bbbc250a1f1550e0a5cc909d3a08cc03b1d2de36d61bfd842881fdb671a2adc57081c8 SHA512 8fa8f50c2c609030c6733385531461a42bdb114c3d9812a66a250a9600e35a51500e0f848722a216f0fa828b8648323150ad95f47fd47eba5f3fd2a594cce76a
+MISC metadata.xml 395 BLAKE2B 5d6c5c889169be1f1e05eadc0cefcbe90d51c4c7400aef7d1c653c4a018f5288384c30b7f58d8502d0c1ffb2c07aa08a81cca7e4d12b5df7ef344fabd13ee7a5 SHA512 bfcf70da768f5a66edc1ed98211ced383bac3ea1ca2313efc7caac197aeeba1c988fbd738b7118afdc775ed30b43ee8af42c9c39da82eefadb88e87802f6f8e4
diff --git a/dev-python/pytest-toolbox/metadata.xml b/dev-python/pytest-toolbox/metadata.xml
new file mode 100644
index 000000000000..0b43cf3a3e28
--- /dev/null
+++ b/dev-python/pytest-toolbox/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-toolbox</remote-id>
+ <remote-id type="github">samuelcolvin/pytest-toolbox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
new file mode 100644
index 000000000000..ffff5bfb4ec7
--- /dev/null
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Numerous useful plugins for pytest"
+HOMEPAGE="https://pypi.org/project/pytest-toolbox/ https://github.com/samuelcolvin/pytest-toolbox/"
+SRC_URI="
+ https://github.com/samuelcolvin/pytest-toolbox/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}