summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 13:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 13:01:09 +0000
commitacc2dacf2ee9a5b03df96da670153f2e3a24d80c (patch)
tree852bc5b5f64c3dc59ac09c6a2314c63b9a901ac0 /dev-python/pytest-timeout
parent2c9b8fbe41c04a94054b0540b54fcf2de0b79166 (diff)
gentoo auto-resync : 23:03:2024 - 13:01:09
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest4
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild44
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild2
3 files changed, 2 insertions, 48 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 625e156030b3..5d6eaed1a206 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-timeout-2.2.0.tar.gz 16391 BLAKE2B 550b803ed4a64ab0fead7f6e61297ea6bfc6e59988998c5383fdccdebb3664fe9f6651314bb1a439f6431e844bb770feb50bedcabd568e4dfea7526d8c328dd7 SHA512 11a0c4e958b324bff3e149bf2a7dc5bf6ab6549405d5061856f8f1ad0e43df1cddce83df4c804b717276bfbcfcf60ee6b400625d0f4e4e73c98785146c22164f
DIST pytest-timeout-2.3.1.tar.gz 17697 BLAKE2B 5f0ffa2fdda59ef28a92bfd5742891f63c1fa400db4ef89077fa13d917932d83e76d543c4c326a27df582a025122d8a75f1f7adf0daebbecc42273d4323ff93a SHA512 f200d625d11f76173521f4e2e4e09d57f6613d9b1420c57893b454ec496d5f11b32390b95eb995b403d15f8563b742a58fa0e0cbad42246b4049787a389ad83e
-EBUILD pytest-timeout-2.2.0.ebuild 1092 BLAKE2B 7864c24b6680df40408be51c56e8bdf89e9864199533ae4dfe139772982919bae52865c50c127361e6adb2b2068b2aa31a5bbb13b8ee762ff54791143c67101b SHA512 3e0eb9ca90a92f443fc01b1807ba926c92c264c6761b85d2f574d1d1c83fe83b9b1da556dd9512e6a5a9ae9925c1357392ebb62b54817e1d1fd7110a6fae2ed0
-EBUILD pytest-timeout-2.3.1.ebuild 1078 BLAKE2B 627be1d83953628b7aa4d299264cd26389e35044f537beed2e0db23418d91e052693e52b38cc9f6b6393f7ee1db1860196241d675cf9b1c5c019b328a07ac4e7 SHA512 23249dee7d0c4f2a27cf511e722551740c1e584d1bdfd7cdfebac3153f8b2fff72fceeff5823253b4b5707682289086a58846b64afbafcf41ae2fb5e96b25896
+EBUILD pytest-timeout-2.3.1.ebuild 1070 BLAKE2B dbef48b0368f757406bba30fab73df6044abd36e3ececc9a782f04d6c7589243f930ecfc01488176a9a7223c63c44ea0c34724c71d65c30193a37f97abc1d875 SHA512 901299703bfd066c21634c18742fe9a9873081c45bed34eb87eba35477e1d5a8f1e93602bd118fcc3bb86e354f6c76efd1e62db9182770435bd936228f23e92c
MISC metadata.xml 420 BLAKE2B ff56de441243acbf2c7332acf224c8f64427378a8cd5f56c040eca1bcaae467459d8ae09409a963d0053a95035a4e7cfcda067d5be78bcd24ba222b2ce56d6f4 SHA512 c6b4ebdd5bd59452d0952e50526ca9b7cb5b88b12d989947a4775d60cdc9315d594ca7c37cb17c0cd4b2708d08db625f678fd577ac9031e0b0e6dbb364a6ad3a
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
deleted file mode 100644
index 5faedcdf1e13..000000000000
--- a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="pytest plugin to abort hanging tests"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-timeout/
- https://pypi.org/project/pytest-timeout/
-"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-# do not rdepend on pytest, it won't be used without it anyway
-# pytest-cov used to test compatibility
-BDEPEND="
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- !hppa? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
- test_pytest_timeout.py::test_disable_debugger_detection_flag
- )
-
- epytest -n "$(makeopts_jobs)" --dist=worksteal
-}
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
index ea860f7df388..2d48986cbf02 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
# do not rdepend on pytest, it won't be used without it anyway
# pytest-cov used to test compatibility