summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-timeout
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest5
-rw-r--r--dev-python/pytest-timeout/metadata.xml11
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.2.0.ebuild24
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.2.1.ebuild24
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
new file mode 100644
index 000000000000..cde822e0bba0
--- /dev/null
+++ b/dev-python/pytest-timeout/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-timeout-1.2.0.tar.gz 13258 BLAKE2B 71c137fb0440c15cc8285b4bef51405a6b53deb850c109d1a892159e8758c712e9d1bae8f400adadf1b85cf399c0b87bd2cab51d959b4eb68023052f6c42788c SHA512 b86548843e9ff8c8f7d1c39735025cdfa98befe2860e2a8a5d422d08bd7f542032384f147125a2a2841268154cc3a3874ef0aa4765d454fd5390edb773b106ae
+DIST pytest-timeout-1.2.1.tar.gz 11498 BLAKE2B 65b50ed52409ed0031c7c9b07ef5b96c088cdf98c0155c1a6405e701fbddc2da1070a9f5a63e22428bd2d18e0ad4eec4050239f7d786fa854256c86eb6be0b1b SHA512 749a0dad83b82e93a97a8590900f2285679ec368612fdcfe3f5f7a5b64774ac85196dc31df111c6a99efda92dc03f751f17ec20862bed1f6aea7d7e4140a06bb
+EBUILD pytest-timeout-1.2.0.ebuild 554 BLAKE2B e0140a7281591e383bb4c72970e91bfef3a1aa13bea29ffaedb642a8ab9ec83bad62ce47d2b06f5ca6b5748e2640c3a6908b93d04809a0f2bedc03c9275de6e6 SHA512 4b935ad08eb1db17d14c6700d17010158d9d3742c986073abf9d41cc3f48a9fd89b5f7deb2e118ccdae69cd19cc4e33b2d845c56d9f5a5fbd083c7f1369b8c5f
+EBUILD pytest-timeout-1.2.1.ebuild 563 BLAKE2B 3d35c7c4ec76682f9adf43c234574fe78dadb58baa8c0545a34f9e89ef21738e96fa81d4b719274d505ef6153d0baa769c6f627f234c55e1b0038edcc1df84ff SHA512 1ea4de221603eaf9aac3d76c59146c5ab4afcc157404172032986b1a3821e0bde31e3da54672cd681466390a63f858a8dafa36c79c92c99b6c9d2fdd2407261c
+MISC metadata.xml 327 BLAKE2B 23dc2e5e6f023223ab4774206b2d94fd27fc0a6b2592c8e0c317e1c1a0e7c26ed4f8e23187c5499b7fc9c4acc0df601a056ab1dced8115a47a9e72697037fa32 SHA512 6040289d134f65896f2fb80538d9caa4ce628911c5ed21568a30087d1b0ffb14b9acbf874956720b1d9c56290c78bb965ac9299bc400fd89a258f3627180780a
diff --git a/dev-python/pytest-timeout/metadata.xml b/dev-python/pytest-timeout/metadata.xml
new file mode 100644
index 000000000000..53c928b91c5a
--- /dev/null
+++ b/dev-python/pytest-timeout/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-timeout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.2.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.2.0.ebuild
new file mode 100644
index 000000000000..2db7247a8c7d
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ ${EPYTHON} test_pytest_timeout.py || die
+}
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.2.1.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.2.1.ebuild
new file mode 100644
index 000000000000..e7a02de3673e
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}