summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytest-timeout
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest2
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index f352b84080c0..626d27923c72 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,4 +1,6 @@
AUX pytest-timeout-1.4.2-optional-cov.patch 839 BLAKE2B adc39941d090788666a5fa74d602fc7c2d7252622d5d213f8308728df7f198faf82edd9d56b3bb3cc277e62608cc6f59909ddce881e1a5931dde1f21f3671d32 SHA512 adb234da8272cf1b61d80db6d9c2b99cb0297044a962f3f54c7d9991ec8a142e6df3eb95fb29ee56326b3bd89e8af6d754f3c92f21a9fce934cd5d0af7fe4d05
DIST pytest-timeout-1.4.2.tar.gz 15424 BLAKE2B b7ab91833e59af56ae50c066c14bb9b8ae9995d1586f35b29f107665d7da124828d7accc1b0149702f2973c61f18024739c68de736ae8aae6f55e8a10bf5d4ff SHA512 3446ecdb5aaad5fbca12df4e7f4f40c6c1a12895d3ed9f3a3ee24800ce36deed3cb8c09a4cc72220c962b06f821cfd55bf7eebbca23664c56abf2d0e5bc8fbea
+DIST pytest-timeout-2.0.0.tar.gz 16210 BLAKE2B 8e3c0436147b6cc680540329daabd7269d301c95663599f7e9c64313bc3a45fde5cc5ea297d5b8c85f43d1a80c2db44b8e150877c3c7b29eef5e38426dfd4efc SHA512 96e9b545b4ac1e4a615863f69d190e0265e85f23dc12df51e9035b8e6bceff23279bb042eed83aa0ddd6d06b0e02a2dcc29ee352fd44cc86f0682fb328264645
EBUILD pytest-timeout-1.4.2-r1.ebuild 845 BLAKE2B 4012f45527042dfe78e888647feda657e447176b638049c73a557b30208a3204057fe5a21813ee2648b5a3833dc9634f6c51cbb1f414c80cb6b912a1ef1e474d SHA512 a0f3e201c15cb22929223e63ce6cdd56fdc31229bce3292b5713fc3a45ce541816ef5f3125405e2823f08eb3116223d95aefe342542d466affd915130ac110cf
+EBUILD pytest-timeout-2.0.0.ebuild 741 BLAKE2B 6de6780693c9093002057a80b2115d666c3d0f8d4d3f7490555f94fbbc780cd12ef23628b21162e3b8e41f99ac5762e5756c4b64d2dfeb8e5a1ca1c75e5a29f1 SHA512 70e729b6a241a24defbc03b78fee26a832b740e47424d4de86a3f2134b2eb155285355e9382bbd516b5fd865544294ea648e63f77ed4e70e75a4ab188b0aecca
MISC metadata.xml 353 BLAKE2B 4865119ec7c91f6d9ac1ab4ce5b1cb73b784f29f7efd669c629062cca2d433eaabb51af1d0ddb3275d414a99413eb8aa76c8639d484c7846ea33c4f53a013bad SHA512 764118890125a80df18e5d9a1bbf6bb35261c0cbcc04e6c9c67ee7b307cdbc31979b831910022a1caef97deee6830d7236f258f524a95a9494229dcd4a14c8ad
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild
new file mode 100644
index 000000000000..5be23064f839
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ )"
+
+distutils_enable_tests --install pytest