summaryrefslogtreecommitdiff
path: root/dev-python/pytest-timeout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
commit35d60f48c1e8e3d48626e53a1933c55805177d20 (patch)
tree0754900eff547564866e4e7265a5f0789874f907 /dev-python/pytest-timeout
parentdd14643cac4a1aa6ce4151cea5c424577434968b (diff)
gentoo auto-resync : 10:10:2023 - 12:09:13
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest2
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild21
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index ff66dd6758f3..04289c9a14ab 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,5 +1,5 @@
DIST pytest-timeout-2.1.0.tar.gz 18386 BLAKE2B 1c84b67e8d07056f9c5b188e467832d4aa292ce1047da6cb13b2939962d2599853db134b16ff3a1a953cbdc1c1772be961eadc9925b32f8dbe514938ede90d40 SHA512 5750e5183669ed9b83fbb76bd7fc9fc1f5f6eef3d9b675dc44f6c7edfd2c6d15739d71e845ededaa192c93da73026ac3376a3295be9f7d3f3eac325660ce7bf3
DIST pytest-timeout-2.2.0.tar.gz 16391 BLAKE2B 550b803ed4a64ab0fead7f6e61297ea6bfc6e59988998c5383fdccdebb3664fe9f6651314bb1a439f6431e844bb770feb50bedcabd568e4dfea7526d8c328dd7 SHA512 11a0c4e958b324bff3e149bf2a7dc5bf6ab6549405d5061856f8f1ad0e43df1cddce83df4c804b717276bfbcfcf60ee6b400625d0f4e4e73c98785146c22164f
EBUILD pytest-timeout-2.1.0.ebuild 794 BLAKE2B 5191792a1dd44fd7e74dd0a1424ef2539321caa21bfea60bf74a421286e742e75c4e5028fa06c630ad8ef049156aa1135f97bad056d8ea6ba608a02f6ff00363 SHA512 8873202b09704d0bebd197ee3cac5213c59ce70ab430cc94b7f2dfbd31b1a30464204ac34dd6731ae0ccca582a5bdb307a91dfee0bd5d2cba3e22d7a4f104448
-EBUILD pytest-timeout-2.2.0.ebuild 1019 BLAKE2B 82654483fad3d2e9c5fb0a9dc855866f269a5564a5a7f36c7489aaaff324c24bae203a90b7ed531be5ac344b64c91f4de0740991b5bf53a9a0aa893a5dc5b96d SHA512 3a4d9c6807d4d99dcc650c63f88164cf5a73b84c31eaac2f757929548afa4c26c22bc0125224e09a5d4bbbd82b87f5df25f61597f5c6993cd9882fae88d76dd1
+EBUILD pytest-timeout-2.2.0.ebuild 1100 BLAKE2B 29721b1b4409a7b40e6e8f941ef0e900ca14611eb8f6a92bccd7dadbdcf4f81200a8936e123143149b51b8b678ecddab26f944158d428c9fbf34fb7d7523a6da SHA512 2d7efb98d5337a5f81cbcd63b149eec98f0215e1ceb72d276c0024d34923d8fc9fc55888f1cfc2326183aaa9585852ee0fdcf7a185161f869cb86063a89d1622
MISC metadata.xml 420 BLAKE2B ff56de441243acbf2c7332acf224c8f64427378a8cd5f56c040eca1bcaae467459d8ae09409a963d0053a95035a4e7cfcda067d5be78bcd24ba222b2ce56d6f4 SHA512 c6b4ebdd5bd59452d0952e50526ca9b7cb5b88b12d989947a4775d60cdc9315d594ca7c37cb17c0cd4b2708d08db625f678fd577ac9031e0b0e6dbb364a6ad3a
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
index 0201b80b5b46..7c49baaa6924 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.2.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit distutils-r1 pypi
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="pytest plugin to abort hanging tests"
HOMEPAGE="
@@ -24,18 +24,21 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~
BDEPEND="
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
!hppa? (
- $(python_gen_cond_dep '
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- ' python3_{10..11} pypy3)
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
)
)
"
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # TODO
- test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
- test_pytest_timeout.py::test_disable_debugger_detection_flag
-)
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test_pytest_timeout.py::test_suppresses_timeout_when_debugger_is_entered
+ test_pytest_timeout.py::test_disable_debugger_detection_flag
+ )
+
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}